Safari Missing Quicktime Plugin

Discussion in 'Mac OS X Lion (10.7)' started by feins, Jul 21, 2011.

  1. feins macrumors member

    feins

    Joined:
    Aug 11, 2010
    Location:
    Malaysia
    #1
    I've just notice my Lion have issue as my Safari had missing Quicktime Plugin i've try to play and quicktime content from Apple advertisement or quicktime trailer all can't be play and i get a missing plugin message.:eek:

    How can i install back the plugin pls help.:(
     

    Attached Files:

  2. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #2
    Check to verify if you have the plugin installed by going to Safari --> Help --> Installed Plug-ins. Scroll down until you see (or don't see) Quicktime.

    If it's not there, run Software Update and see if it's there and download it. If not go to apple.com/quicktime and download it there and see what you get.
     
  3. feins thread starter macrumors member

    feins

    Joined:
    Aug 11, 2010
    Location:
    Malaysia
    #3
    I've check as the method you mention and the plugin for QuickTime 7.7.1 was display. I've even check at the Internet plugin folder I also saw QuickTime plugin are there.

    I've try download QuickTime from www.apple.com/QuickTime/ but during install it prompt need snow leopard to install but I'm using lion now.

    I run software update and it prompt not update available.

    It didn't happen on my MBW and MP but only happen on my MBP.
     
  4. john54 macrumors newbie

    Joined:
    Jul 22, 2011
    Location:
    Ohio
    #4
    Same Problem Here

    I've had exactly the same problem as feins and I've tried exactly the same things. I did a new download of Qucktime and it made no difference at all. My browser also showed that it had the plugin loaded.:confused:
     
  5. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #5
    I found this here, see if it works:

    Try the following steps:
    1) Open the folder Macintosh HD/Users/your_user/Library/Preferences
    2) In this folder, search the file com.apple.quicktime.plugin.preferences.plist
    3) Open it with Textedit
    4) Search for this string (without the quotes) "<key>application/x-shockwave-flash</key>"
    5) On this section, change the "<true/>" string to "<false/>" (without the quotes)
    6) Save and quit Textedit
    7) Relaunch Safari and ENJOY!!!!!
    8) After you follow these instructions, don't open the MIME Setup on the quicktime Preference Panel -> Advanced or you will revert the boolean back to yes (and will have to change it to no again). This is indeed a bug in Quicktime Preference Panel
     
  6. john54 macrumors newbie

    Joined:
    Jul 22, 2011
    Location:
    Ohio
    #6
    Entry Not Found in Library

    There is no entry for "com.apple.quicktime..." in the Library folder. Puzzling, huh?
     
  7. john54 macrumors newbie

    Joined:
    Jul 22, 2011
    Location:
    Ohio
  8. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #8
    They probably changed the name of it to one of the ones listed in the screen shot. Likely the com.apple.quicktimeplayer.plist. Or the com.apple.quicktime.plugin.preferences.plist.

    Also if you want to correct something in a post you already made, use the Edit button in the lower right of the message to make your correction instead of adding another post to correct a previous one. That is a violation of the forum rules, just so you know. :)
     

    Attached Files:

  9. john54 macrumors newbie

    Joined:
    Jul 22, 2011
    Location:
    Ohio
    #9
    QuickTime Installed but...

    Thanks for the hint. I discovered the edit icon after I posted the second reply.

    I do have the QuickTime player installed but nothing about quicktime or quicktimeplayer in the Preferences. I do have a QuickTime entry under Library which has some codec components but that's about it.
     
  10. rogercrocha macrumors newbie

    rogercrocha

    Joined:
    Jul 27, 2011
    #10
    I was able to fix this my removing, restarting and re-installing the Perian plug-in to all users in my machine.

    I also uninstalled all other plug-ins, except for the QuickTime player plug-in, just to make sure. But it seems that the problem resided in Perian alone.
     
  11. feins thread starter macrumors member

    feins

    Joined:
    Aug 11, 2010
    Location:
    Malaysia
    #11
    Too bad i restore the whole machine and update lion again =.="
     
  12. kwamayze macrumors newbie

    Joined:
    Jun 17, 2011
    #12
    Fix Safari missing QuickTime plugin

    Just go to safari preference and the extensions. Look for the DivX extension and uninstall it.

    Then test to see if you can successfully view videos.
     
  13. bberri, Feb 23, 2016
    Last edited: Feb 23, 2016

    bberri macrumors newbie

    Joined:
    Feb 14, 2016
    #13
    Hi, I recently updated to EL Cap. I installed Quciktime via Apple DL(download site) as mentioned in this forum. 1 of primary issue re:quicktime plugin is post install going smoothly, by all accounts i.e.
    installed without issue, Safari via 'installed plugins' view,STILL reads NO quicktime plugin (refs whatsoever)
    Unlike a couple of others here who are also tackling quicktime (plugin) issues, I'm paused to try your suggestion/steps bc of this divergence. I did navigate to the Finder Library/Preferences folder and followed yr steps up the point where you suggest 4. Later today,when I have more time (and more than 3 weeks in trying to solve overlapping issue Netflix worked find for couple days then
    not only freezing my Macbook Pro minute I go to stream anything via Netflix,but I've had to
    ** take battery out of my macbook only way my machine will reboot
    Meanwhile, I surely would try HTML5 setting many ppl are doing w/similar viewing issues etc
    however, NETFLIX Settings,playback... there is NO OPTION to toggle anything, thus, no
    ' HTML 5 '
    Overlapping issue, back to quicktime plugin, as mentioned, I followed your suggestion here up to step 4. at 1st blush, while I did note/see a few 'quicktime..' references in the Library/Preferences..
    folder (step 4) I DO NOT see any 'shockwave' reference in this file at all
    What is that about now? The hits just keep coming.
    My Safari, preferences,security.. (left side column) does include shockwave 'allow' or 'deny' so forth
    in whatever way this may help you help me, I greatly would appreciate it.

    At this writing,even tho I'm running late,I did look well enough scrolling top to bottom for more than 10min I don't think I've missed 'shockwave' in this file you mention, but of course, I easily could have. After nearly a month of this day and day out (since Netflix started acting up and crashing my machine hard) I'm eager to solve these issues.

    Some notable links I found that suggest things are improving; I cam across a link that is expressly set up to test (QT) quicktime plugin
    http://camendesign.com/code/video_for_everybody

    When I visited this site 1st time it played fine. When I clicked on the other link listed, it played fine and in lower right corner read "HTML 5"
    When I took note of this, I went to review what the author on this site wrote in my efforts to learn what this means exactly. Does it mean via my Safari, HMTL 5 is working? bc the video played fine as I said, both times (within the links options he lists) Where read included something about for those visiting, interested in 'code'....I briefly checked it out in hopes of....

    A bit lengthy I know,but this troubleshooting issue it's gaining 'last nerve' momentum.Again, I would greatly appreciate helpful insights, meantime, I know better than start editing step 4. file
    before I'm clear(er) on what /why I'm doing.

    If I forgot to mention it, re: quicktime referene within 1 of the keys I took note of,it's reading <false> where maybe it should be <true> ? I'm not at all certain and before I get ahead of myself here, further,I'll leave it at that.
    Ahead of time,foremost,thank you so much,I really appreciate it.

    Peace
     

Share This Page