Safari: no contextual menu with right-click on link

Discussion in 'Mac Apps and Mac App Store' started by old john, Feb 13, 2010.

  1. old john macrumors member

    Joined:
    Nov 18, 2005
    Location:
    England
    #1
    When going to a linked page in Safari I usually want to open it in a new tab or a new window and occasionally to do other things with it. So I'm used to right-clicking on links to bring up a contextual menu offering me:

    Open Link in New Window
    Open Link in New Tab

    Download Linked File
    Download Linked File As...
    Add Link to Bookmarks...

    Copy Link

    I noticed the loss of this menu when my wife wanted me to look at web pages she had found related to a possible holiday.

    Using Safari in her account on our iMac, I found no menu appeared when I right-clicked on a link. I checked she had the "secondary button" set up OK in the mouse preferences and I also found right-clicking worked OK elsewhere. I then tried other ways of making the menu appear on a link (CTRL-clicking or holding down the left, primary button); neither worked!

    Without quitting Safari I switched back to my account, which had Safari already running and found the contextual link menu was working OK there. So I started comparing my Safari preferences with hers and found no relevant differences, but eventually noticed that she was running Safari 4.0.4 and I was still running 4.0.3.

    (What had happened was that Safari had been updated to 4.0.4 from the system operator's account, but, as my account was still logged in, no reboot had been possible. This resulted in my wife and me having different versions of Safari loaded on our accounts simultaneously!)

    It seemed strange that Apple should remove this contextual menu, so we tried quitting Safari in her account and reloading it, but still the menu didn't appear.

    Surely Apple hasn't removed this very useful menu in the 4.0.4 update!

    Please can anyone throw light on this issue for us?
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Have you restarted or repaired the permissions via Disk Utility to see if the problem remains?
     
  3. old john thread starter macrumors member

    Joined:
    Nov 18, 2005
    Location:
    England
    #3
    Thanks spinnerlys. As Safari 4.0.3 was still working OK in my account, I hadn't considered that any repairs could help, but thinking about it now you mention it, I suppose that, as 4.0.3 was running in memory, something that needed repairing could have happened to the HD since 4.0.3 launched. So that is perhaps something we should try . . .

    However, I found this:

    This is from <http://support.apple.com/kb/HT3949>

    That seems to describe the problem except that it should only stop it for links to local HTML files, but it seems to affect all links in our case. So our problem seems to relate to this. Can someone please confirm that the link contextual menu normally does appear OK in 4.0.4? (I should perhaps have mentioned we are running 10.4.11 on a G5, which is one of the OS versions that this notice refers to.)
     

Share This Page