Safari not connecting to the internet, but Firefox is..?

Discussion in 'Mac Apps and Mac App Store' started by istanbul05, Apr 8, 2010.

  1. istanbul05 macrumors member

    Joined:
    Oct 13, 2007
    #1
    Hi since i reset my router all my Apple created software is not connecting to the internet. This includes mail, safari, itunes store, software update. But the strange thing is, Firefox works fine. When i try to load up a webpage in Safari, it hangs on the loading status for about a minute before saying it cannot load. I have also tried removing the wireless network and starting again but the same thing happens. In network settings it says that the connection to the internet is fine.

    I have tried resetting Safari and clearing the cache but i have had no luck.
    Anyone got any ideas?

    Thanks
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    You have enabled connection to the Internet via proxy in the Network preferences pane. Firefox is unaffected because for its proxy access can only be enabled within Firefox's own preferences.
     
  3. istanbul05 thread starter macrumors member

    Joined:
    Oct 13, 2007
    #3
    Hi thanks for the reply. So how do i go about solving the problem for the Apple apps?
    Cheers
     
  4. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    You can create a new Network location via Network Preferences. Click the dropdown for Location at the top of the window, select Edit Locations, click +, name it whatever, then click Ok followed by Apply. You should be up and running if it is a proxy issue.
     
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #5
    The problem is not with Apple apps. The problem is that you enabled accessing the Internet via proxy servers. I gather that this was not your intent. If this the case, then you need to disable Internet access via proxy servers:
    • Launch System Preferences.
    • Click the Network preferences pane.
    • Select Show: Built-In Ethernet. [In MacOS X 10.6 (Snow Leopard), select your active connection protocol--AirPort, Ethernet, etc. Then click the Advanced... button.]
    • Click the Proxies tab.
    • Uncheck any that may be checked.
    • Click the Apply Now button.
    In the event that you intended to connect to the Internet via proxy, launch Firefox and System Preferences. Replicate your Firefox proxy settings in the Network preferences pane.
     

Share This Page