Safari not loading all pictures on page

Discussion in 'Mac Apps and Mac App Store' started by UKingdom, May 19, 2007.

  1. UKingdom macrumors member

    Joined:
    Apr 28, 2007
    #1
    on some pages i can open fine with my PC, i notice on safari the page doesn't fully load or takes forever to load, and a lot of the images just end up being little blue boxes with question marks in it. the status bar on the bottom of the page says it's loading but it takes forever. on firefox on my pc it doesn't have any problem loading at all. even using firefox on the mac it's slightly improved but still doesn't completely load. is there any tips you guys could provide to explain what's going on?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Okay, well maybe give us a link to some of the pages that aren't loading so that we can try to find something in common. :)
     
  3. UKingdom thread starter macrumors member

    Joined:
    Apr 28, 2007
    #3
    it's mostly on pages where there are lots of imageshack thumbnails which fail to load, but they load fine on my pc.
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Okay, do the Mac and PC share the same connection to the 'net? For example, are they both on a wireless network? :)
     
  5. merc669 macrumors 6502

    merc669

    Joined:
    Jun 7, 2006
    Location:
    Southern MD, USA
    #5
    Here is an example;

    "mapwow.com"

    Will not load correctly on Safari but Firefox it loads just fine....

    Bill.....:apple:
     
  6. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    In your example, Safari doesn't load the map properly but loads the rest of the images correctly. Is this the same for you?


    Picture 2.jpg


    The weird bit is that I find Safari is fine with regular Google maps. Thanks for the example. I'll keep looking into it.
     
  7. patrickq macrumors member

    Joined:
    Mar 23, 2005
    #7
    I find Safari useless a lot of the time, in fact there are days I wonder what all the fuss about Macs being so good is, the software all seems to have been designed by computer geeks who have no concept of the real world outside of computers, in this I include iPhoto and iTunes, both have so many deficiencies and cannot handle simple tasks efficiently, kind of a scaled down variation of what Microsoft users have to tolerate every day.

    I get the same problem with Safari, it refuses to load images sometimes (where Camino will).

    It also has an annoying habit of saving pages with a location descriptive, not the original page url, so when you open it later you have no idea where the original page was online. Another brilliant design concept is that you can't open the page unless it is in the same location you saved it, I mean what kind of idiot designs a system like that!!!

    Yes, its one of those days :)
     
  8. merc669 macrumors 6502

    merc669

    Joined:
    Jun 7, 2006
    Location:
    Southern MD, USA
    #8
    That's exactly what I see. And as you say, Google Maps loads correctly. It is strange. Thanks for the verification!!

    Bill.....:apple:
     
  9. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  10. Hoopn macrumors newbie

    Joined:
    May 29, 2007
    #10
    Me Too

    This same problem happens to me when I go to facebook.com..its frustrating
    :mad:
     

Share This Page