Safari not loading pages, other browsers doing fine

Akarin

macrumors 6502
Original poster
Oct 16, 2011
290
17
Nyon, Switzerland
Hi,

I have an issue many seem to have: Safari 7.0.5 (and now 7.0.6) hangs when loading web pages whereas other browsers (Chrome, Firefox) work just fine. I've ran my tests on WiFi with two different routers as well as through iPhone tethering.

Here are the steps I have taken so far but the problem persists:

- re-installed my MacBook Air completely with the latest image from the App Store
- Reset Safari
- Disabled extensions
- Unchecked "Warn when visiting fraudulent website"
- Unchecked "Stop plug-ins to save power"
- In the Develop menu, checked "Disable caches"
- In WiFi settings, disabled IPv6
- Changed DNS to OpenDNS
- Deleted all Safari plist, caches, favicons cache, etc.
- Turned off Safari in iCloud settings
- Fixed permissions, rebooted
- Disabled the prefetch setting from terminal
- Emptied all my logs, launched Safari and tried to open this url: https://pragprog.com/login . Here is the (anonymised) result:

24/08/14 21:21:35.340 com.apple.launchd[1]: (com.apple.WebKit.WebContent.561A6831-7FA6-4E02-9B5B-FD48490AD905[346]) Could not terminate job: 3: No such process

24/08/14 21:21:35.340 com.apple.launchd[1]: (com.apple.WebKit.WebContent.561A6831-7FA6-4E02-9B5B-FD48490AD905[346]) Using fallback option to terminate job...

24/08/14 21:21:35.340 com.apple.launchd[1]: (com.apple.WebKit.Networking.89C22912-D84A-4B32-8401-468739D3BCED[287]) Could not terminate job: 3: No such process

24/08/14 21:21:35.340 com.apple.launchd[1]: (com.apple.WebKit.Networking.89C22912-D84A-4B32-8401-468739D3BCED[287]) Using fallback option to terminate job...

24/08/14 21:21:35.346 com.apple.launchd[1]: (com.apple.WebKit.Networking.89C22912-D84A-4B32-8401-468739D3BCED[287]) Exited with code: 1


I also deleted all the passwords in my keychain, deleted all the bookmarks and emptied the reading list, just in case there was some corruption there. Still no success.

Any help with this issue is greatly appreciated, it's driving me nuts and currently have to use Chrome.

Also, it seems others have the same issue as I have but so far, couldn't find an answer: https://discussions.apple.com/thread/6501064?start=0&tstart=0

(and my original thread in Apple support forum, with even more console logs: https://discussions.apple.com/thread/6500707 )
 
Last edited:

Bizcocho

macrumors newbie
Aug 11, 2014
2
0
I have the same issue on all of Yosemite DPs. I did inplace upgrade on all. I also have the same issue on IOS8 for both my iPhone and iPad.
 

Akarin

macrumors 6502
Original poster
Oct 16, 2011
290
17
Nyon, Switzerland
I have the same issue on all of Yosemite DPs. I did inplace upgrade on all. I also have the same issue on IOS8 for both my iPhone and iPad.
That doesn't sound too good for my problem, then. I was kinda expecting Yosemite would make the issue go away. I have a dev version of Yosemite but on my Mini which never had the issue with Safari my MBA currently has.
 

Fishrrman

macrumors Core
Feb 20, 2009
19,645
6,844
Would you care to provide us with the URL's of the pages that won't load?
 

Akarin

macrumors 6502
Original poster
Oct 16, 2011
290
17
Nyon, Switzerland

Fishrrman

macrumors Core
Feb 20, 2009
19,645
6,844
OP:
I just tried all the links you provided in the post above, and they all load for me.

Late 2012 Mac Mini, 10.8.5, Safari 6.0.5.
 

NunoBerny

macrumors regular
Feb 12, 2012
195
0
Lisbon, Portugal
Here, the ONLY page (so far) that won't load is this one:

https://www.portaldasfinancas.gov.pt/pt/inicio.action

The URL bar fills halfway through then it stops. It also prevents from opening pages on other tabs for a while.
This is a page I used about once a week for years without any problems.
Friends with other platforms access the page just fine.

Could someone using a similar setup test it for me?

MacMini,Safari 7.1 on Mavericks.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.