Safari Not Loading

Discussion in 'iPhone Tips, Help and Troubleshooting' started by birdy89, Apr 18, 2011.

  1. birdy89 macrumors newbie

    Joined:
    Feb 12, 2011
    #1
    Hi there If anyone has been through this situation can you please share your story.

    So I have an iphone 4 / 4.2.1 and just recently my safari page doesnt even load up for me no more. Im left with a white blank page thats frozen. However when i go on wifi then load up safari it works just fine so is there something wrong with my 3g data? i mean all my other apps that require 3g works just fine but for some reason safari just doesnt load no more and this is just recent :confused:
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    Is it a specific website? Have you tried clearing the caches in Settings?
     
  3. birdy89 thread starter macrumors newbie

    Joined:
    Feb 12, 2011
    #3
    safari

    nothing at all will load not even my google engine... like right when i click safari to go in i get blank page and cant type anything like it froze...when i get on wifi then go on safari boom everythings normal
     
  4. wad11656 macrumors member

    wad11656

    Joined:
    Feb 20, 2009
    #4
    If it's jailbroken and you have AdBlocker, get rid of it. Worked when my device's Safari didn't work at all...
     
  5. birdy89 thread starter macrumors newbie

    Joined:
    Feb 12, 2011
    #5
    thanks

    oh man i should of thought of adblocker i added it last week when this started too thanks for the tip man:D
     

Share This Page