Safari not opening some clicked links?

Discussion in 'iPhone' started by Megalobyte, Oct 16, 2011.

  1. Megalobyte macrumors 6502a

    Joined:
    Dec 30, 2007
    Location:
    Florida
    #1
    When i searched I found many people are having this issue with their iPads, but the exact same thing is happening to my iPhone. It seems to happen when you try to click on a highlighted/underlined link someone, for example, stuck into a post of theirs. Safari appears to open that page in a second window, but the window stays blank. If you go back to the original window with the link, then go back to that second window it opened for that link, now, magically it's there.

    I saw many people post about it in the iPad section but not about their iPhones. Well, it's definitely happening on my iPhone 4s eith 5.0.

    It seems to happen on manually inserted links, like: here, check this out, then they copy/paste a clickable URL/link into the body of their post. Click on it, opens it in a new window, only, that page is blank, until you go back to the first page, then go back to the new page again, now it's not blank.

    Anyone else?
     
  2. Violent_Noir macrumors newbie

    Joined:
    Oct 15, 2011
    #2
    I'm having this problem too. The link will be on the top of the page but not in the bar. I've just been copying & pasting as an alternative.
     
  3. mgmusicman94 macrumors 6502a

    Joined:
    Nov 16, 2008
    #3
    It's a bug. The workaround is to go back to the tab you clicked the link in, wait a second, and go back to the new tab. It has to load in the background for some reason and will most likely be fixed in the next update!
     
  4. Vundu macrumors 65816

    Vundu

    Joined:
    Jun 10, 2009
    Location:
    Manchester, UK
    #4
    Happened for me in the betas and I reported it. Hoped it would of been fixed:confused:
     

Share This Page