safari not quit

Discussion in 'macOS Sierra (10.12)' started by peixesloucos, Nov 8, 2016.

Tags:
  1. peixesloucos macrumors member

    peixesloucos

    Joined:
    Dec 1, 2012
    Location:
    Brussels
    #1
    Hi, my system is up-to-date. When I try to logout Safari (10.0.1) ends up with the rainbow and do not quit. I need to ask for a force quit each time.
    Any one having the same issue?
     
  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    I'm assuming your attempts to "log out" are attempts to Quit the application. What method(s) for doing this have you used?
     
  3. elf69 macrumors 68000

    elf69

    Joined:
    Jun 2, 2016
    Location:
    Cornwall UK
    #3
    To quit I use Command Q

    I have 10.0.1 safari on sierra and on el capitan.
     
  4. peixesloucos thread starter macrumors member

    peixesloucos

    Joined:
    Dec 1, 2012
    Location:
    Brussels
    #4
    I do few options:

    1. cmd+Q
    2. I use alfred and type the relevant code "quit safari"
    3. If I do not do anything and just try to logout from my macbook pro (shift+cmd+Q) without closing any applications including safari

    With all it just makes safari unresponsive. I wonder if this could be relating to any extension, I do not use many.

    Or perhaps I need to reboot the macbook pro.
     
  5. BaggieBoy macrumors 6502

    BaggieBoy

    Joined:
    May 29, 2012
    Location:
    UK
    #5
    I have this quite a lot ever since the first Sierra beta. More often then not Safari will not quit normally and a force quit is needed.
     
  6. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #6
    I have not had this problem in Sierra. Have you tried removing your extensions to see if it's better?
     
  7. peixesloucos thread starter macrumors member

    peixesloucos

    Joined:
    Dec 1, 2012
    Location:
    Brussels
    #7
    I tried removing the extensions did not work but a restart of my macbook pro helped.
    Not sure why this happened but now the problem is solved!
     
  8. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI

Share This Page