Safari not updating through App Store on El Cap

Discussion in 'OS X El Capitan (10.11)' started by benbranca, Aug 13, 2017.

  1. benbranca macrumors newbie

    benbranca

    Joined:
    Apr 30, 2017
    #1
    I updated my Mac Mini the other day to OS X El Capitan, and I noticed that Safari wasn't updated. I went to update it through the App Store, and when I clicked Update, it said "Installing", then it went away and said Update again. Ive restarted, tried updating on other user accounts, and updating other apps in a bundle with Safari. Can someone help me?


    Thanks in advance!



    -Ben


    This is a Mac Mini 2009 2.0 Ghz and with 2 gigs of RAM.
     
  2. Ebenezum macrumors 6502a

    Joined:
    Mar 31, 2015
    #2
    My first advice is to increase the RAM on your Mini, 2 GB is the minimum amount needed to use El Capitan and you should install at least 4 GB RAM for it to work at reasonable speed. RAM is quite cheap these days.

    As for the problem there are some things you can try:

    1. Restart Mac while holding Shift key until you see the login screen, then login normally and try update again. It will remove caches, temporary files etc. which might cause the problem.

    2. Next step is Terminal because Apple unfortunately doesn't provide standalone downloads of Safari etc. software, if you have no experience with command line it could be somewhat scary. You can find Terminal with Spotlight (upper right corner, magnifying glass) type terminal into Spotlight.

    Copy the lines after : mark to Terminal. First you check what updates are available: softwareupdate --list

    Then you install updates: sudo softwareupdate --install nameoftheupdate
    Alternatively sudo softwareupdate --install -a to install all available updates

    If you install update which requires reboot such as 10.12.6 update (Safari may or may not require reboot) first wait until Terminal notifies you to restart Mac, then use sudo reboot command and wait until Mac completes install & reboot.
     
  3. benbranca thread starter macrumors newbie

    benbranca

    Joined:
    Apr 30, 2017
    #3
    Thanks for helping, that fixed it. I've ordered some more RAM, its just taking a while to ship :p



    Thanks for the help!
     

Share This Page