Safari not working on "quite" a few sites...

Discussion in 'macOS Sierra (10.12)' started by whohasaquestion, Jul 21, 2017.

  1. whohasaquestion macrumors 6502a

    Joined:
    Sep 17, 2011
    #1
    I think these sites have some kind of Javascript or else going on...that's why it's not working properly. For instance:

    https://herschel.com/contact

    after clicking "Submit" on the contact form, I get nothing from Safari, as if it's been ignored, so I had to switch to Chrome browser to submit. This happens on a few other sites as well. Below are my safari setting. What am I doing wrong here? I've toggled uBlock extension on and off with no avail.

    Thanks to anyone who cares to help!


    Screen Shot 2017-07-21 at 11.07.21 AM.png Screen Shot 2017-07-21 at 11.07.54 AM.png
     
  2. whohasaquestion thread starter macrumors 6502a

    Joined:
    Sep 17, 2011
    #2
    Alright, so I am able to answer my own question now.

    uBlock being the culprit. Even after disabling, it still wouldn't allow certain feature on website to run. Uninstalling it solves the mystery.

    Case closed.
     
  3. got556 macrumors 6502

    got556

    Joined:
    Jul 7, 2013
    Location:
    Indiana
    #3
    I'm still having this issue. Started all of a sudden. Reset router, unplugged router, cleared DNS cache, tried google servers, tried different browsers (Chrome, Safari, Firefox), uninstalled Adblock....nothing seems to be working.
     
  4. whohasaquestion thread starter macrumors 6502a

    Joined:
    Sep 17, 2011
    #4
    Enable Java and webGL and see how it goes.
    Disable popup blocker in Safari too.
     
  5. Tech198 macrumors G5

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #5

    Good it works. but i wouldn't exactly say a "blanket", its uBlocks issue.... When using it you have fine control over what can be displayed, and blocked... if Ublock wasn't working, then that means u haven't set it up correctly. It's either too hard, you end up uninstalling it anyway, or you do the extra mile and whitelist stuff u want to assets/websites u want to allow in dynamic mode (which is disabled by default) (Probably a first issue for everyone)
     

Share This Page