Safari Not Working

dtalksall

macrumors member
Original poster
Jan 24, 2013
43
2
I have an iPhone 7, it's on iOS 10.3 I've tried clearing browser history, restarting phone, closing out apps... Safari is not working for me on WI-FI or Cellular. All other apps are working just fine. This has been going on for 3 days now (even before updating to iOS 10.3)
Anyone else having this issue?
 

Goatllama

macrumors 6502a
Jun 24, 2015
617
631
Mountaintop Lair
What exactly do you mean by 'not working?' Opens but with a blank page? Opens and then immediately crashes? Opens but says no connection? Gimme some symptoms. :D

And do you have any extensions / adblockers / etc. installed? Check Settings > Safari > [whatever the particular section is called, might be content blockers or something] for any culprits perhaps. If nothing's found there, you may just need to restore the device.
 

dtalksall

macrumors member
Original poster
Jan 24, 2013
43
2
By not working I mean I type something in the browser, and nothing ever loads. It just sits on a blank page. No ad blockers.
 

Goatllama

macrumors 6502a
Jun 24, 2015
617
631
Mountaintop Lair
Got it. Do you have the 'Safari' switch turned on in iCloud? If so, turn it off (choosing 'delete') and try then, see if it makes a difference. Play around with the switches (perhaps Java) in the Safari settings maybe. Do a Force Restart (holding down Home and Sleep/Wake until you see :apple:), and as a last resort do the restore. Or do some searching on the internet some more, as there very possibly might be something of which I'm unaware.
 

dtalksall

macrumors member
Original poster
Jan 24, 2013
43
2
Very strange. It does happen every once in a while, but it's never lasted for 3 days straight.
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
48,950
17,598
I have an iPhone 7, it's on iOS 10.3 I've tried clearing browser history, restarting phone, closing out apps... Safari is not working for me on WI-FI or Cellular. All other apps are working just fine. This has been going on for 3 days now (even before updating to iOS 10.3)
Anyone else having this issue?
Have you tried resetting network settings?
 
  • Like
Reactions: Goatllama
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.