SAFARI only showing a gray screen when clicked on. What can I do?

Discussion in 'iPod touch' started by steve-q54, Jan 13, 2010.

  1. steve-q54 macrumors newbie

    Jan 1, 2010
    Website not showing...All I see is gray. If I tilt the iPod, sometimes the bottom toolbar will show up, then it will disappear.

    Anyone have a similar problem? If so, what did you do to get Safari back up and running?

    using touch 3rd gen.

    Thank you greatly
  2. dvdhsu macrumors 6502a


    Mar 28, 2008
    Palo Alto, CA
    Have you tried restoring?

    Typically, a restore fixes most software problems.
  3. JediMeister macrumors 68040

    Oct 9, 2008
    Does it show the gear and the word "Connecting..."?

    Before taking the drastic step of a restore, I would actually suggest clearing the Safari cache/history/cookies, or restarting the iPod itself. To clear the Safari items, go to Settings->Safari, scroll to the bottom and tap each button individually. Then try opening Safari again. To restart the iPod, hold the sleep/wake button for 4-5 seconds until the "slide to power off" bar appears at the top, slide, wait about 15-30 seconds, and then hold the sleep/wake button to power it back on. Then try again.

    Took a screenshot of when I saw this issue after upgrading to 3.0:

    Attached Files:

  4. nocomment1 macrumors newbie

    Jan 15, 2010
    I am also having that problem right now with my 3rd gen itouch.

    I tried to delete all the items on safari and when i went back to it, it still showed up as a gray screen. However, after restarting my itouch I found that the safari was working again. Hopefully it has worked out for you as well.

Share This Page