Safari opens at login, a new behavior I want to stop.

Discussion in 'macOS' started by durija, Feb 10, 2012.

  1. durija macrumors 6502

    Joined:
    Jan 16, 2008
    Location:
    Seattle
    #1
    This is on my MacBook Pro running Snow Leopard 10.6.8.
    Everytime I start up the machine, Safari opens. I don't normally even use Safari, so it's particularly annoying. This behavior started just a few days ago.

    Safari is not in my login items, and I can't think of any other reason it would do this. Any help?
     
  2. arjen92 macrumors 65816

    arjen92

    Joined:
    Sep 9, 2008
    Location:
    Below sea level
    #2
    Sometimes I close safari and one minute later I shut down my iMac. When I restart it, it automatically opens safari. So maybe you should close safari a while before you shut down your mac?
     
  3. durija thread starter macrumors 6502

    Joined:
    Jan 16, 2008
    Location:
    Seattle
    #3
    Again, I don't normally even have Safari open.
    I only use Safari if there is some scripting on a page that Opera can't handle.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Right-click on the Safari icon on your Dock and make sure "Open at Login" is not checked. Then check the first 3 items on the following list.

    Performance Tips For Mac OS X
     
  5. durija thread starter macrumors 6502

    Joined:
    Jan 16, 2008
    Location:
    Seattle
    #5
    That was it. I didn't even know that was in the contextual menus for the dock. Duh! Thanks much!
     
  6. durija thread starter macrumors 6502

    Joined:
    Jan 16, 2008
    Location:
    Seattle
    #6
    I spoke too soon. Although I unchecked "open at login", Safari reappeared at next startup. So I went through the 3 other items mentioned. To be brief, a Quicksilver Safari plugin was the culprit. No plugin = no Safari on startup.
     

Share This Page