Safari opens up in small window...

Discussion in 'OS X El Capitan (10.11)' started by StarShot, Apr 11, 2016.

  1. StarShot macrumors 6502

    StarShot

    Joined:
    Mar 31, 2014
    #1
    El Capitan 9.0.3

    A week or so ago, Safari started opening in a small window. Hitting the "green" dot expands it to full screen, but I'm starting to find this very annoying. Anyone know how to make Safari open in full screen mode?
     
  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    In normal operation, Safari opens the way it was configured when you last Quit the program. Do you use Quit to get out of it? If you just hit the red dot, you have not Quit the program.
     
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    What is "El Capitan 9.0.3"?
     
  4. StarShot thread starter macrumors 6502

    StarShot

    Joined:
    Mar 31, 2014
    #4
    This happens whether I quit with the red dot, click on Safari and put down the menu to "Quit Safari", right click on the Safari icon at the bottom of the screen or click on "force quit" Safari. On another board, I saw this response to the problem.,,

    Try deleting the cache associated with Safari.

    Open the Finder. From the menu bar top of your screen click Go > Go to Folder

    Type this exactly as you see it here: ~/Library/Caches/com.apple.Safari/Cache.db

    Click Go

    Move the Cache.db file to the Trash.

    Quit then relaunch Safari to test.

    At least one reply said this work for him, but it doesn't work for me.
    --- Post Merged, Apr 12, 2016 ---
    A type, it was meant to be the version of Safari. My El Capitan is 10.11.3
     
  5. Swampbaby985 macrumors member

    Swampbaby985

    Joined:
    Nov 25, 2013
    Location:
    East Texas
    #5
    I've been randomly getting this as well. It's a bit annoying really.
     
  6. Sko macrumors regular

    Sko

    Joined:
    Oct 17, 2009
    Location:
    Germany
    #6
    For me it goes something likes this:
    Open new Safari window. Resize and move window to your liking. Close window. Every new windows should open in the new size and location.
    Make sure to do nothing else but opening, resizing & moving, closing. No site loading, no searching.
     
  7. StarShot thread starter macrumors 6502

    StarShot

    Joined:
    Mar 31, 2014
    #7
    I think I just discovered what causes the problem and how to make it go away. A while back (maybe several months) I saw a Safari Extension called "Resizeme2". At the time it seem like something I would like. A few minutes ago, I found this extension under Safari Preferences and noticed the "enable" button wasn't checked. After enabling, Safari now opens in full screen mode. Now I have to do a little research is see if I really have any use for this extension. If not, I'm removing it from the computer.
    --- Post Merged, Apr 12, 2016 ---
    If you have the "Resizeme2" extension, see my reply above. Fixed my problem and yes, I will agree it's VERY annoying.
     
  8. Swampbaby985 macrumors member

    Swampbaby985

    Joined:
    Nov 25, 2013
    Location:
    East Texas
    #8
    No I do not have that extension installed, up until you said anything I'd never heard of it before.
     
  9. StarShot thread starter macrumors 6502

    StarShot

    Joined:
    Mar 31, 2014
    #9
    Then you might try the procedure below...

    Try deleting the cache associated with Safari.

    Open the Finder. From the menu bar top of your screen click Go > Go to Folder (GO is located at the top bar)

    Type this exactly as you see it here: ~/Library/Caches/com.apple.Safari/Cache.db (easier to copy/paste)

    Click Go

    Move the Cache.db file to the Trash.

    Quit then relaunch Safari to test.

    At least one reply said this work for him, but it doesn't work for me.
     

Share This Page