Safari, Opera, Firefox not working anymore - Chrome works

Discussion in 'OS X El Capitan (10.11)' started by Beliblis, Apr 25, 2016.

  1. Beliblis macrumors regular

    Joined:
    Dec 31, 2011
    #1
    Hi,

    My MacMini just crashed half an hour ago. First restart showed a circle with a cross. Second restart worked fine, but ever since then Safari, Opera, Firefox and App Store didn't work anymore. (I've solved the problem as I was writing this, but please keep reading...)

    I mean – they opened, yes. But ANY html I type in just wouldn't open. I tried deleting com.apple.Safari.plist but that didn't help.

    Safari: "Safari can't open the page .... because the server unexpectedly dropped the connection."
    Opera: "There is something wrong with the proxy server, or the address is incorrect."

    I never used a proxy server, so that's where I got suspicious. Quick google search and I found something on Stackexchange: to go to Safari and change the proxy settings. So I did, and I found that under System Preferences/Network, the Web Proxy and the Secure Web Proxy settings were checked.

    Thing is: I never(!) touched these Proxy Settings (didn't even know they existed), and no-one else has access to my computer.

    So... what is happening here??? How can these settings all of a sudden change???
     
  2. dsemf macrumors regular

    Joined:
    Jul 26, 2014
    #2
    The first thing I would do in your situation is download Malwarebytes and check for malware.

    The other thing to look at is whether you have installed any anti-virus software recently. They sometimes use proxies to scan incoming content.


    DS
     
  3. Beliblis thread starter macrumors regular

    Joined:
    Dec 31, 2011
    #3
    Thanks for your answer – and sorry for the late response. (Malwarebytes didn't find any malware).
    It took a while to figure out what's happening, but now I know:

    I'm using a software called "Jaksta" from time to time. It's a software that downloads videos in the background. Basically: If the Jaksta app is open, every time a video starts to play, Jaksta downloads it automatically. Great for downloading tutorial videos from vimeo, for example.

    Everytime I launch Jaksta, it changes the HTTP and HTTPS proxy settings. A little bit annoying, but at least it's harmless I guess. Don't know why Jaksta is doing this, because video downloads work fine with the standard/non-proxy settings...
     

Share This Page