Safari plugin will not load

Discussion in 'macOS' started by Spyharpy, Jan 14, 2010.

  1. Spyharpy macrumors member

    Spyharpy

    Joined:
    Apr 12, 2003
    Location:
    Bay Area, CA
    #1
    I have a question about Safari plugins. I was running under Tiger and got the SplashID desktop program with Safari plugin. Worked beautifully. I decided to upgrade my OS to Leopard so I can use a newly purchased Magic Mouse. Launched Safari and the SplashID plugin would not load. I replaced Safari, its preferences and other files and the plugin will not load. It worked fine in Tiger. I happened to have another internal drive loaded with Leopard from a while back and it's fully updated. I booted from it and installed SplashID and the plugin. Works perfectly! So, why will the Safari plugin not load on my primary drive that was upgraded from Tiger to Leopard versus the same Leopard on my other drive that was a clean install?
     
  2. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
    #2
    Did you download/reinstall SplashID in Leopard? "It worked fine in Tiger" doesn't mean it will work fine in Leopard if you haven't updated the software in ages.
     
  3. Spyharpy thread starter macrumors member

    Spyharpy

    Joined:
    Apr 12, 2003
    Location:
    Bay Area, CA
    #3
    Sure did. Leopard is up to date and did a fresh install of the most updated SplashID software and plugin. I used the same installer to install it on the other Leopard drive that had a clean install of Leopard. It works on that drive. Something isn't allowing the plugin to work on my primary drive that was upgraded to Leopard.
     

Share This Page