Safari Preferences Not Saving

Discussion in 'OS X El Capitan (10.11)' started by Jazwire, Oct 27, 2015.

  1. Jazwire macrumors 6502a

    Jazwire

    Joined:
    Jun 20, 2009
    Location:
    127.0.0.1
    #1
    Any changes I make to Safari Preferences, don't seem to save.

    Example If i change home page to say Google.com (or anything).
    I close down Safari, open it back up and it changes back to:
    http://www.apple.com/startpage/

    If i change " New Windows Open With" to anything other than the default (Favorites) they change back as well.
    Nothing seems to stay.

    Any ideas?
    I've tried clearing cookies, history.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Try this... quit Safari. Then triple click the line below to select the folder path. Then right click and in Services menu select Reveal in Finder. Open the Preferences folder and scroll down to com.apple.Safari.plist and delete that file.

    Now restart your Mac then open Safari. That should put your Safari settings back to default and allow you to make changes.

    Code:
    ~/Library/Preferences
     
  3. Jazwire thread starter macrumors 6502a

    Jazwire

    Joined:
    Jun 20, 2009
    Location:
    127.0.0.1
    #3
    Nope :/

    I found the plist, and deleted it. Rebooted the computer and it didn't recreate the file.
    (I did back it up on Dropbox first, and was able to put it back and reboot.)
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    When you launch Safari for the first time it will recreate the file. It sounds like you rebooted and looked for the file. It won't be there until you start Safari.

    Repeat the process to delete it and reboot... then start Safari and it should be at defaults.
     
  5. Jazwire thread starter macrumors 6502a

    Jazwire

    Joined:
    Jun 20, 2009
    Location:
    127.0.0.1
    #5
    Fixed, I was deleting the plist from /Library not /(user)/Library.
    It works now, thanks. ;)
     

Share This Page