Safari problem

Discussion in 'iPod touch' started by adauge, Sep 15, 2007.

  1. adauge macrumors regular

    adauge

    Joined:
    Sep 15, 2007
    #1
    When I am using safari on the ipod touch it doesn't let me click in search fields or click on any links. Basically I can only get to the home page of each site. Is anyone else having this problem and if not can anyone think of something I'm doing wrong.
     
  2. Luigi239 macrumors 6502a

    Joined:
    Jan 25, 2007
    #2
    I have had this problem before. Usually I just open a new page, and it fixes itself.
     
  3. adauge thread starter macrumors regular

    adauge

    Joined:
    Sep 15, 2007
    #3
    Yea, I've tried everything. I've exited out of safari, plugged it back into itunes. Nothing.
     
  4. adauge thread starter macrumors regular

    adauge

    Joined:
    Sep 15, 2007
    #4
    Thanks for the help. I tried going to other pages but never actually tried opening a whole new window but it worked. Thanks again.
     
  5. texasguy macrumors newbie

    texasguy

    Joined:
    Jun 28, 2007
    Location:
    Houston
    #5
    Had trouble with searches too...

    You're right! Although I opened a new window and still had an issue. Then I powered off and on and tried again and it's fine. These are just minor glitches which I'm sure will be resolved in future software updates. If I had to count the number of updates we've had for our previous iPods, I'd be hard pressed to do so as there have been so many--each correcting problems and improving features.
     
  6. rusty. macrumors member

    rusty.

    Joined:
    Sep 22, 2007
    Location:
    Houston, Texas
    #6
    Even using Safari for Windows XP it does that to me but I just leave it alone for like a few seconds and it works again.
     
  7. parrotheadmjb macrumors 6502

    Joined:
    Mar 4, 2007
    #7
    hold down the sleep and home button for 10 seconds to do a soft reset
     

Share This Page