Safari problems on iPad 2

Discussion in 'iPad' started by Grubster, Mar 13, 2011.

  1. Grubster macrumors member

    Joined:
    Jun 25, 2010
    #1
    I setup my new iPad 2 and instead of setting up as new, I restored from my previous gen 1 iPad. Everything seems fine, but safari seems to crash a lot. Sometimes it is a weird crash and when I go to view the tabs, the screen is three quarters white. I have to close it out from the app tray and restart safari. Seems to happen when opening new tabs.

    I have other weird things where it turned like all crazy blocky colors across the top. Weird things I never seen on my iPad one which I have had since it launched.

    Do I just need to restore and setup as new? Or is this a iOS 4.3 issue?
     
  2. vincenz macrumors 601

    vincenz

    Joined:
    Oct 20, 2008
    #2
    Sounds like something bugged when you restored from the old one. Try a fresh one and see if it happens.
     
  3. Merrily2006 macrumors newbie

    Merrily2006

    Joined:
    Jun 11, 2006
    Location:
    Central Coast, NSW, Australia
    #3
    Nope not bugged

    ..it happened to me today too - Ipad 2 new yesterday. Browsing web pages and then boom - Ipad crashed and rebooted itself. I opened Safari again and it repeated the same deal - this time with the weird screen colours and blocks.

    After doing this three times I did a hard reset and it seems to be OK BUT all my open pages had disappeared.

    Never had this issue with iPad 1.

    Anyway - my husband bought a new ipad2 yesterday as well - and the same thing happened to him just now as well :(
     
  4. ghostlyorb macrumors 6502a

    ghostlyorb

    Joined:
    Jan 9, 2010
    Location:
    Virginia, USA
    #4
    Sounds to me like it might be that you're running out of RAM. Try a restore and see if that helps. My iPhone used to crash Safari a lot.. but now it doesn't.
     
  5. brudog68 macrumors 6502

    Joined:
    Feb 20, 2011
    Location:
    TN USA
    #5
    Has happened here too. Seems it's been after linking to another tab and trying to go back. Gotta be a bug in safari somehow.
     
  6. Merrily2006 macrumors newbie

    Merrily2006

    Joined:
    Jun 11, 2006
    Location:
    Central Coast, NSW, Australia
    #6
    Going with the RAM suggestion

    Think I agree that it may be a RAM issue ....

    Tonight my three day old iPad 2 really panicked.
    I was google mapping and zooming in and out a bit so it had to re render the screen ..
    iPad 2 crashed and had a lot of trouble getting back up again The apple logo would appear then after a bit a vertical line came up on the screen and down it would go again Happened for bout eight cycles. I tried to intercept with a hard reset a couple times till finally it got it's act together Phew I thought it was a gonner there!

    Think I'll call Apple support tomorrow morning so that at least they have a record from early days in case this keeps up..
     

Share This Page