Safari problems

Discussion in 'Mac Apps and Mac App Store' started by Oktober, Jul 20, 2012.

  1. Oktober macrumors regular

    Joined:
    Dec 16, 2008
    Location:
    Great Britain of United Kingdom
    #1
    I am not sure what is going on with my Safari, but in youtube it acts up completely. When playing a video, the related videos on the right don't show up, just blank boxes; changing the size of the video and quality makes the player/safari almost unresponsive and when you close Safari down the sound from the video is still playing momentarily.

    I have the latest version of safari on SL being 5.1.7. Whether it is my 6mb broadband connection, I have flash player installed and is up to date. But Firefox seems fine - but I prefer using Safari a little more.

    Anyone have a solution for my problem for something I have overlooked?

    Cheers
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    Your connection is bordline, but you could try emptying your Safari cache, and re setting it

    Top menu bar > empty cache

    Same> re set safari

    This may help clear junk, but 6MB is pretty low for real time videos etc.
     
  3. Oktober thread starter macrumors regular

    Joined:
    Dec 16, 2008
    Location:
    Great Britain of United Kingdom
    #3
    I 'Reset Safari' very often. At least once a week approx.
     
  4. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #4
    Some videos don't work in Safari because there is no Flash application permitted on Apple products. That might be part of the problem. However, I can get most videos - even movie streaming - on my MBP late 2011 with Verizon's rip-roaring "high speed" internet connection of 3 mbs.
     
  5. Oktober thread starter macrumors regular

    Joined:
    Dec 16, 2008
    Location:
    Great Britain of United Kingdom
    #5
    Thanks. I will bear that in mind.
     

Share This Page