Safari refreshes on Swipe Back

Discussion in 'OS X Yosemite (10.10)' started by shahin90, Feb 1, 2015.

  1. shahin90 macrumors regular

    Joined:
    Oct 23, 2012
    #1
    Hey guys,

    I really wanna use Safari as my main browser since it's super smooth and stuff, but I HATE how when I swipe back I need to refresh pages.

    Is there a fix to this? Why can't apple fix this? This is the ONLY reason I still use Chrome.
     
  2. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #2
    I posted about this some time ago, it seems apple has done this to make Safari appears faster.
    The Last version of Safari to work correctly in regards to auto refreshing is 7.0.6 which in part is why I'm still running Mavericks.
     
  3. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #3
    I'm not At home to try this on Yosemite but if you close safari fully then open terminal and type

    defaults write com.apple.Safari IncludeInternalDebugMenu 1

    Then relaunch safari do u get the debug menu in the top bar??
     
  4. shahin90 thread starter macrumors regular

    Joined:
    Oct 23, 2012
    #4
    It's really the stupidest thing. It makes me wonder if people at Apple use safari themselves or is it just me getting annoyed the **** out.

    ----------


    I did that and nothing happened.
     
  5. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #5
    It's changed in Yosemite to an option in the preference settings but unfortunately the option I was going to get you to disable which would have solved this has also been removed. Sorry
     

Share This Page