Safari regularly stalling whilst opening a webpage

sunking101

macrumors 604
Original poster
Sep 19, 2013
6,671
1,812
This used to happen on a different iPhone with iOS6, and also my current iPhone with iOS6 and iOS7.

Quite often Safari will start to load a website and the blue progress bar will stick at approx 1/8th of the way across. No amount of page refreshing will budge it and I have to force-close the app to get it to start loading webpages again. This happens two or three times per day.

I had thought this was an iOS6 problem so I'm kinda annoyed that it has migrated to iOS7 too. Funnily enough, I don't remember it happening all that often with 7.0.4

Does anyone else experience this?
 

kingdom23

macrumors regular
Oct 31, 2011
129
3
Happens to me from time to time. I have to quit Safari and reload the page again.
 

TommyA6

macrumors 65816
May 15, 2013
1,056
516
This used to happen on a different iPhone with iOS6, and also my current iPhone with iOS6 and iOS7.

Quite often Safari will start to load a website and the blue progress bar will stick at approx 1/8th of the way across. No amount of page refreshing will budge it and I have to force-close the app to get it to start loading webpages again. This happens two or three times per day.

I had thought this was an iOS6 problem so I'm kinda annoyed that it has migrated to iOS7 too. Funnily enough, I don't remember it happening all that often with 7.0.4

Does anyone else experience this?
Yes... Happens more often than on 7.0.6 (I don't remember it happening on 7.0.6 at all actually)
 

jdag

macrumors 6502a
Jun 15, 2012
827
212
Same here. I find that clearing out history seems to temporarily help the stalling. It also seems to, at least for a while, help web pages to load more quickly.