Safari running super slow!!!!

Discussion in 'Mac Apps and Mac App Store' started by nwendt, Sep 28, 2008.

  1. nwendt macrumors newbie

    Joined:
    Feb 18, 2008
    #1
    I would say about 2 days ago, safari started to run at the speed of dial up. It is driving me nuts, I hate going on my mac right now!!!! I really do not know much about computers so, if someone could help me... I would appreciate it!!! I am running OSX 10.5.5 idk y it's so slow!!
     
  2. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #2
    Are you a Comcast subscriber? Is your ISP throttling your speeds? Is someone else on your network?
     
  3. Gray-Wolf macrumors 68030

    Gray-Wolf

    Joined:
    Apr 19, 2008
    Location:
    Pandora, Home Tree
    #3
    1. Restart your computer
    2. Empty the Cache
    3. Repair your permissions.
     
  4. nwendt thread starter macrumors newbie

    Joined:
    Feb 18, 2008
    #4
    i am running a road runner, there is a pc on my wireless network, put it kills my mac on internet speed.

    idk how to empty the Cache, or repair permissions.
     
  5. Samarium macrumors 6502a

    Samarium

    Joined:
    Jan 6, 2008
    Location:
    @ home.
    #5
    Try Firefox. If you see a significant difference, well use Firefox instead of Safari.
     
  6. nwendt thread starter macrumors newbie

    Joined:
    Feb 18, 2008
    #6
    i just hooked a cat 5 cable up to my computer and safari is still running slow!! so idk

    yeah firefox is just as bad if not worse, i don't get it bec when i download stuff it downloads at 750 kps
     
  7. Sorkvild macrumors 6502

    Joined:
    Feb 23, 2007
  8. Gray-Wolf macrumors 68030

    Gray-Wolf

    Joined:
    Apr 19, 2008
    Location:
    Pandora, Home Tree
    #8
    To repair permissions, click on finder/applications/utilities/disk utility app/the icon that is your hard drive. then click on the Repair Disk permissions.

    Simple. The restart the computer and try the internet then.
     
  9. Phazer80s macrumors regular

    Joined:
    Jul 25, 2002
    Location:
    Above the 49th
    #9
    Have you been viewing Window Media files? Are you using the Flip4Mac plugin? If so i'd suggest installing the plugin, restarting your system, and giving Safari a go again.

    Prior to the latest update WMV files would consistently clog up Safari on my system. I'd have to restart the program to get the sludge out. Just reseting it did nothing.

    After the upgrade to 2.2.1, WMV files have cased no problems. I'm running 10.4.11 on a G4. Your results may vary. Good luck!
     
  10. dirt farmer macrumors 6502

    Joined:
    Feb 23, 2005
    #10
    I've been reading about this DNSchanger trojan that's been mentioned a lot this week. It supposedly causes web browsing to come to a slow crawl.
     
  11. Tosser macrumors 68030

    Joined:
    Jan 15, 2008
    #11
    Safari has been slow as molasses for me since, I believe, 10.5.2.
    The only remedy that works is emptying the cache, then deactivate the cache, and then empty again. I have to do it every time I have loaded just a single page after start up. But from then on, the cache is deactivated and everything is fine. It sucks having to do it, though.

    Omniweb (also using webkit) doesn't have this problem – at least I haven't encountered it.
     
  12. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #12
    ok fair enough. but before we diagnose this as the cause we first but ask nwendt if she/he has installed any QuickTime codecs recently which required the input of an admin password in the Installer application (besides Flip4Mac).

    this trojan changes DNS settings so if you are infected addresses (non grey) will be added to the DNS Servers list in System Preferences>Network>Advanced>DNS.
     
  13. yoyo5280 macrumors 68000

    yoyo5280

    Joined:
    Feb 24, 2007
    Location:
    Melbourne, Australia & Bay Area
    #13
    I dont quite understand this post. Our internet has started slowing down in the last week, and today we found DNSchanger on our computer.After isolating and deleting it we still have slow internet. How do we reset our DNS settings.
     
  14. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #14
    ^ go to DNS in Network preferences and delete the addresses. you may already have some grey inactive addresses, they are fine and are probably from your router.
     
  15. yoyo5280 macrumors 68000

    yoyo5280

    Joined:
    Feb 24, 2007
    Location:
    Melbourne, Australia & Bay Area
    #15
    ^^
    Turns out we didnt delete the file. We did it for real this time.

    My dad said he "flushed" the DNS settings and now everything is back to normal! WIsh I could inform the genius bar. Had been there twice.
     
  16. jacobluecke macrumors member

    jacobluecke

    Joined:
    Dec 19, 2007
    Location:
    Jefferson City, MO
    #16
    I'd second the Open DNS suggestion. It's easy to try and I had a similar problem a week ago that Open DNS completely solved.

    Give it a shot!
     
  17. nwendt thread starter macrumors newbie

    Joined:
    Feb 18, 2008
    #17
    the open dns seams to be working good as of now thanks guys
     

Share This Page