Safari Slow Under Yosemite With Bluetooth Switched On

Discussion in 'OS X Yosemite (10.10)' started by Chris1969, Oct 19, 2014.

  1. Chris1969 macrumors newbie

    Joined:
    Jul 24, 2014
    #1
    Hi folks,

    Spec: MacBook Pro (Late 2013), 2.6 GHz i7, 16 GB

    I'm finding that Yosemite makes Safari run very slowly if Bluetooth is switched on. Anybody else having the same problem? If Bluetooth is switched off, the problem resolves itself immediately.

    I've tried a PRAM reset, and a disk permissions fix, but neither to any avail. Could the problem be a bug?

    Many thanks,

    Chris1969
     
  2. Jeff Flowerday macrumors regular

    Joined:
    Aug 23, 2007
    Location:
    Calgary, AB
    #2
    Safari Slow Under Yosemite With Bluetooth Switched On

    From what you describe it's a handoff thing. Turn off handoff and see if it performs better with Bluetooth on.
     
  3. Chris1969 thread starter macrumors newbie

    Joined:
    Jul 24, 2014
    #3
    Hi Jeff,

    Thanks for the suggestion. I've unchecked the box in System Preferences / General / Allow Handoff..., but unfortunately that hasn't helped.

    I'm using an iPhone 4S near my Mac, but I still get the problem even with the phone switched off. (As far as I can see, there is no menu for turning off Handoff on the iPhone itself.)

    I've noticed that Safari works particularly slowly with Bluetooth switched on if the webpage contains a lot of graphics or images (rather than just text).

    Any other ideas gratefully received!

    Best,

    Chris1969
     
  4. KingArthurVI macrumors regular

    KingArthurVI

    Joined:
    Dec 17, 2011
    Location:
    Minneapolis, MN
    #4
    Wow, I upgraded to Yosemite 2 days ago and noticed significant lag in Safari, didn't know it was related to Bluetooth being on. I turned BT off and the problem fixed itself immediately. Thanks OP for the tip, but I really do wish this gets fixed. :confused:
     
  5. Chris1969 thread starter macrumors newbie

    Joined:
    Jul 24, 2014
    #5
    Hi KingArthurVI,

    I think I may have discovered the problem. I think the slowdown is caused by Bluetooth looking for devices that are not within range, or switched off. In my case it was a UE Boombox. If you go into Bluetooth / Open Bluetooth Preferences, and delete any devices from the list which are not actually being used, then things seem to speed up.

    All the best,

    Chris1969
     
  6. Chris1969 thread starter macrumors newbie

    Joined:
    Jul 24, 2014
    #6
    PS - something else which seems to help is turning off certain extensions. AdBlock in particular seems to slow things down with Bluetooth switched on. No idea why...
     

Share This Page