Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

fanspeed

macrumors member
Original poster
Feb 17, 2007
74
0
I have a mid 2007 iMac. safari has been running slow lately. When i use Chrome browser it zooms like it use to. But am use to all the ins and out of Safari. I did all the things suggested. restting Safari, clearing browser, and so on and so on.
I even reinstalled the OS. and no improvement. Any suggestions? Thanks for reading
 

rkaufmann87

macrumors 68000
Dec 17, 2009
1,760
39
Folsom, CA
I have a mid 2007 iMac. safari has been running slow lately. When i use Chrome browser it zooms like it use to. But am use to all the ins and out of Safari. I did all the things suggested. restting Safari, clearing browser, and so on and so on.
I even reinstalled the OS. and no improvement. Any suggestions? Thanks for reading

First ensure your extensions are up-to-date, after doing that then test. If it's still slow then click Safari-Reset Safari-choose all options and reset it. Then restart the computer in Safe Mode to clear some caches and restart normally and re-test.
 
Comment

fanspeed

macrumors member
Original poster
Feb 17, 2007
74
0
thanks

thanks gang working ok now. seems after reinstalling snow leopard my safari version was 5.0.5 ,updated to 5.1.9 and is back to normal.
 
Comment

fanspeed

macrumors member
Original poster
Feb 17, 2007
74
0
safari again slow

happening again. when I use Chrome it zooms, but again I like safari and I'm use to all the little ins and outs of safari. Mid 2007 20"iMac. running snow leopard 10.6.8. :(
 
Comment

Racineur

macrumors 6502
Jun 11, 2013
368
87
Montréal, Québec
thanks gang working ok now. seems after reinstalling snow leopard my safari version was 5.0.5 ,updated to 5.1.9 and is back to normal.

Hi, I had the same problem after applying the last Apple update (2013-002) to SL 10.6.8. Tried everything you did with no success. I was about to reinstall SL when the rep at the cable company suggested to reset the modem which I did and Safari 5.1.9 (along with the other browsers) became zippy as usual.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.