Safari stopped loading images on every page out there

Discussion in 'iMac' started by Creativedot, Feb 13, 2013.

  1. Creativedot macrumors newbie

    Joined:
    Feb 11, 2011
    #1
    Hello...

    while i was working on my wordpress theme i noticed that safari suddenly stopped loading images.. So i tested other webpages like yahoo, cnn, ebay etc etc.. Content loads but NO IMAGES! Google.com doesnt have the google logo,..just a search bar..:confused:

    What is going on? How cani fix this? All other browsers are fine...its just safari that gone mad. Please help!
     
  2. Creativedot thread starter macrumors newbie

    Joined:
    Feb 11, 2011
    #2
    ....there must be a way to fix this.... anyone out here had the same problem before?
     
  3. benjaminfoden macrumors member

    Joined:
    Feb 9, 2013
    #3
    Have you tried Resetting Safari? I believe its in the Application Menu...
     
  4. pete78 macrumors member

    Joined:
    Jan 14, 2011
    #4
    Before my HD crapped out on my brand new maxed out 2012 27inch iMac, Safari would not fully load pages at least 30% of the time; I would have to click reload a few times for the pages to load fully. In the end, a minor annoyance compared to having a DOA HD on a nearly $3000 machine. Still, if my replacement iMac (whenever I get it) has this Safari issue, I will try to get to the bottom of it. Very annoying, but right now I have bigger problems (i.e., dead iMac and relying on my 8-year old Dell, which in the end has been MUCH more reliable than my two-week old dead iMac). End of rant.
     
  5. Creativedot thread starter macrumors newbie

    Joined:
    Feb 11, 2011
    #5
    Just tried resetting..no luck!

    @ pete78 ...it just wont load images no matter how many times i try to reload the page. It happens 100% of the time. It just refuses to show any image on any site... very weird...!:eek:
     
  6. bflowers macrumors 6502a

    Joined:
    Jul 19, 2006
    #6
    Try this:

    Check the Develop menu
    Images may be turned off in the Develop menu, even if it isn’t visible now. If the Develop menu isn’t visible, choose Safari > Preferences, click Advanced, and then select “Show Develop menu in menu bar.”

    Open the Develop menu and make sure Disable Images doesn’t have a checkmark beside it.
     
  7. pete78 macrumors member

    Joined:
    Jan 14, 2011
    #7
    That is indeed VERY weird and not normal, obviously. If you can't figure it out, just dump Safari and go with Chrome or another browser.
     
  8. Creativedot thread starter macrumors newbie

    Joined:
    Feb 11, 2011
    #8
    bflowers...THANK YOU! :D

    i was going mad...i am a web developer and i need it for testing..i may have typed a key combination on my keyboard that triggered this... it was in the dev menu...images where disabled!

    Thanks for your help guys!:)
     

Share This Page