Safari Stopped Working After Trying to Install Firefox

Discussion in 'Mac Apps and Mac App Store' started by lia77, May 5, 2008.

  1. lia77 macrumors member

    Joined:
    Jul 23, 2007
    #1
    I downloaded and installed Firefox, seemed to be working fine. Turned off my MacBook, next time I tried to use Firefox, it wouldn't connect to the Internet.

    I had Safari installed in my MacBook also, tried to connect to the Internet with it and wouldn't work either. I then uninstalled Firefox (or rather moved the program to the thrash bin), and still Safari would not connect to my Internet wireless broadband signal.

    Help!!!! What is wrong with Safari and/or with Firefox? The Internet signal is working fine since the other computer in the apartment is able to connect without any problems whatsoever. I tried running the network diagnosis and could not find any errors.

    Is there a way I can go back to the original settings before installing Firefox??

    Please help!
     
  2. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #2
    You have strayed from the Path of Jobs. For shame.

    Restart your computer, base station, etc. See if that helps.
     
  3. lia77 thread starter macrumors member

    Joined:
    Jul 23, 2007
    #3
    Hi, i tried to restart and it still does not work!! The strange thing is that i tried to install an update on my old safari but it did not work, and it said something like that the computer could not install safari...hm, so that is why i went to firwfox...:-(
     
  4. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #4
    lol, I didn't know firefox can attack your internet connection.....:eek:

    1. if you are using wireless, try connect your computer directly with cable see if problem persist

    2. try a different network environment.

    3. what is the error displayed in browser? does your computer menu bar show establishment of wireless at all?
     
  5. lia77 thread starter macrumors member

    Joined:
    Jul 23, 2007
    #5
    Thanks!
    It says Safari cannot connect to internet or something like that. However, the signal on the wireless internet says it is fine!

    Do you know anything about resetting the computer to a previous date? I used to be able to do that on my PC and that way all new programs, etc would disappear after that date... Is that ´possible?
     
  6. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #6
    no, selective file restoration to certain previous version can be done through TimeMachine (such a 1970s name...:)), but when you don't even know which file to restore, its basically useless.

    However, I would suggest you install an app called OnyX, and try to clear system cache with it.
     
  7. lia77 thread starter macrumors member

    Joined:
    Jul 23, 2007
    #7
    Thanks! but i cant connect to internet at all on the mac ( i am on a PC now...) so how can i get the onyx?
    Thanks for your suggestions anyway:)
     
  8. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #8
    well, download it to your pc, and copy it to your mac, install it, and run it.:)
     
  9. lia77 thread starter macrumors member

    Joined:
    Jul 23, 2007
    #9
    OK:) Are you sure it is not going to damage the computer? And what does it do to the mac really??
     
  10. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #10
    disclaimer, I don't guarantee anything....;)

    Its a system maintainer for OSX, haven't heard any problem with it. It just clears out all the caches, or repairs here or there. You can read more on its website.
     
  11. lia77 thread starter macrumors member

    Joined:
    Jul 23, 2007
    #11
    Ok, i will give it a try then! Thanks for the advice:D
     
  12. Trip.Tucker Guest

    Joined:
    Mar 13, 2008
    #12
    You crack me up! One of the funnier posters on this site :)
     
  13. pennypacker macrumors newbie

    Joined:
    Jun 26, 2008
    #13

    I have actually had the exact same problem since installing FF3. FF3 seemed okay at first, but the next day I couldn't browse at all using both FF3 and Safari. Even my GMail Notifier would not make a connection. All indications are that I have a network connection, but I cannot browse. I have tried my wireless connection, my neighbour's wireless connection, and even a wired connection, but none work. If I tinker enough, I can sometimes browse, but it only lasts for a little bit, and then I'm back to square one. Other laptops work just fine on my home network.

    I have also tried the following, but nothing has worked so far:
    - Network Diagnosis
    - Rebooted Airport
    - Restarted cable modem
    - Performed a virus scan using ClamXav (no viruses reported)
    - Performed a spyware scan using MacScan (no spyware reported)
    - Removed cookies
    - Cleared cache

    I am pretty close to either trying to reinstall Leopard using my Time Machine back up, or reinstalling Leopard from scratch unless anyone else has any suggestions.

    Thank You.
     

Share This Page