Safari stuck "connecting" with iPhone 3.0

Discussion in 'iPhone' started by Hecklerdanny, Jul 5, 2009.

  1. Hecklerdanny macrumors 6502


    Aug 27, 2007
    Hey everyone. I have the iPhone 3GS. I don't know if this is local to my phone, or what.

    All of the time, Safari on my iPhone gets completely stuck "connecting" to a website. It grays out everything behind it, and I get the word "Connecting" with a spinning graphic. Anyone else having this issue? A hard reset fixes it only sometimes.

    If you've seen this issue, have you found a way to fix it?

    Thanks in advance.
  2. skball123 macrumors regular

    Sep 11, 2007
    I had the same problem. All I did was restart and it let me use safari.
  3. geekaren macrumors newbie

    Jul 1, 2009
    I've seen this occasionally...
    Either a restart or putting the phone into Airplane Mode for a moment (then turning Airplane Mode off again) should resolve.
  4. iHalo macrumors regular

    Sep 14, 2008
    The few times this has happened to me, I notice I am on wi-fi. I turn off wi-fi, load the page on 3g, go back to wi-fi, and it works.
  5. Peppery macrumors newbie


    Jul 23, 2009
    Auckland, New Zealand
    Strange, this has been happening to me too with my new 3G S. Never happened with 3.0 on my 3G, and I ran all the betas too.

  6. aprofetto macrumors 6502a


    Dec 19, 2008
    Hamilton, Ontario
    I've seen this happen on my 3GS too, even a couple 3GS's in the Apple store did this.
  7. rustyknife macrumors newbie

    Sep 13, 2009
    Bournemouth, UK
    got my 3gs last week, and it doing this too, the only prob i have with the device
  8. fishmoose macrumors 68000

    Jul 1, 2008
    I've had that on my 3G on 2.X firmwares to. A restart always fix it for me.
  9. nateo200 macrumors 68030


    Feb 4, 2009
    Northern District NY
    Happens on my touch all the time. Turn wifi off and try and load it then the turn it back on. If that doesn't work a cold restart should do it.
  10. iphone.zal macrumors newbie

    Oct 31, 2009
    Its your cookie settings

    If you are surfing using a free wireless connection which requires you to log in via a browser, chances are that you will be redirected to the login page.

    However, if you do not enable cookies to automatically accept (ALWAYS), this re-direct will fail and you will be stuck at that annoying page.

    So go to your Safari settings, check Always for Accept cookies and voila...
    Happy surfing...
  11. Yoshimar macrumors newbie

    Feb 22, 2010

    Yes, it always happens when I tried to use a free network.

    Thanks for the solution :)
  12. zevulun macrumors newbie

    Mar 23, 2011
    Tried it all. Just wont budge. The wi-fi symbol keeps going off. This is the first problem i am having with my 3gs:confused:. Need help!
  13. JediMeister macrumors 68040

    Oct 9, 2008
    @zevulun: Your issue sounds like a connectivity issue, not a problem with the Safari app on your 3GS. If the icon defaults back to your cellular data connection, that means your iPhone can't see the WiFi access point anymore. Did you maybe move out of range, did someone near you turn on something that might have caused interference? Did any of the other devices that were on the network at the same time get kicked off? How old is your router, have you updated the firmware?

Share This Page