safari suddenly not doing landscape

Discussion in 'iPhone Tips, Help and Troubleshooting' started by velvetelvis, Jun 8, 2009.

  1. velvetelvis macrumors 6502

    velvetelvis

    Joined:
    Oct 26, 2007
    #1
    so, safari on my phone suddenly wont go into landscape mode. i dont know what happened. i tried rebooting my phone with no success. any ideas as to what might have happened?
     
  2. dukebound85 macrumors P6

    dukebound85

    Joined:
    Jul 17, 2005
    Location:
    5045 feet above sea level
    #2
    that has happened with my touch and iphone

    it doesnt work sometimes (esp if im running) but returns to work after a while

    its weird
     
  3. velvetelvis thread starter macrumors 6502

    velvetelvis

    Joined:
    Oct 26, 2007
    #3
    i have an appt at apple tomorrow. not sure if its still under warranty.
     
  4. velvetelvis thread starter macrumors 6502

    velvetelvis

    Joined:
    Oct 26, 2007
  5. OrangeCuse44 macrumors 65816

    OrangeCuse44

    Joined:
    Oct 25, 2006
    Location:
    Long Island, NY
    #5
    I get this too sporadically. Did you try cover flow to see if it's the accelerometer or just Safari? When this happens to me I cannot engage cover flow either.
     
  6. velvetelvis thread starter macrumors 6502

    velvetelvis

    Joined:
    Oct 26, 2007
    #6
    yea i tried and its both. the accelerometer does work because i can play a game that uses it.
     
  7. velvetelvis thread starter macrumors 6502

    velvetelvis

    Joined:
    Oct 26, 2007
    #7
    ok, so i went into my local apple store (went yesterday but had to make an appt.) and they restored my phone (which i already did) and it still wasnt going into landscape mode, so, they replaced it with a new one. just a 16g 3g and not with 3.0. but hey, it works and thats all i really wanted... thank apple.
     

Share This Page