Safari suddenly slow.

Discussion in 'Mac Apps and Mac App Store' started by maxp1, Jun 22, 2011.

  1. maxp1 macrumors regular

    Feb 12, 2005
    This just cropped up a day or two ago and I'm not sure what to do about it. Using Safari v5.05 on an older Macbook Pro (Santa Rosa Core 2 Duo) running 10.5.8.

    It seems like anything that causes Safari to interact with the internet makes the browser to freeze until the HTTP request is done. New pages, AJAX calls, whatever. Clicks aren't registered until many seconds later. Can't switch tabs, even unloading pages takes second or two. Beachballs are frequent but only last about a second. Everything just halts every time you click something. It's really freakin' annoying.

    I've moved to Firefox and everything loads at normal speeds, clicks are registered fine. Any other application I use works normally. CPU and memory usage is normal, there's plenty of disk space available. I've reset Safari and restarted my computer. That improved things slightly but it's still too annoying to use Safari. I've not installed any new software or made any changes to my system or Safari preferences in a while. Other devices aren't having any difficulty, just Safari on this computer. Mystified.

    Any help?
  2. Badbaw macrumors member

    Jun 17, 2011
    Go through the norm and empty the cache, clear cookies and history. Quit and restart. Maybe even delete the .plist file.

    First check for updates though!
  3. TEG macrumors 604


    Jan 21, 2002
    Langley, Washington
    Also, repair permissions. I've had issues with permissions locking the ability to process two things at a time.

  4. maxp1 thread starter macrumors regular

    Feb 12, 2005
    Ok, not to be snotty to someone offering advice, but try reading what I posted. You'd see that I'm running the current released version and that I've reset Safari and restarted. I did neglect to mention that I've already deleted the .plist though. No improvement.
  5. prissypants macrumors newbie

    Jul 29, 2011
    same problem

    Was this ever resolved???
    I'm having the same problem. Running Safari 5.0.5 and macOS 10.6.8.
    Other browsers are running fine but Safari suddenly takes up to 25sec. to load a simple page.
    Tried turning off extensions, plugins; emptying cache... no diff. Thought it may have to do with having installed "1Password" but after the troubleshooting, not sure that's the culprit. Was on the phone with apple support for hours - tried reinstalling safari, different login account, new network settings...nothing.
    If anyone's found a solution, please reply.
  6. Gregg2 macrumors 603

    May 22, 2008
    Milwaukee, WI
    Longer posts are frequently not read all the way through. I went back and laboriously read the whole thing, which was difficult, as my habit is to skim through quickly. I finally found where you mentioned something you'd tried to do to fix the problem, buried in the third paragraph.

    This is just the reality of our times. If your post is concise and well-organized, this wouldn't be as likely to occur. Something like this:

    The problem:
    blah blah blah

    What I've done:
    blah blah blah

    Can you help?

    Just my two cents. You can take it or leave it, obviously.

    More things to try:
    For what it's worth, I also run 10.5.8 and just updated Safari to 5.0.6 the other day. It runs fine. You could try that.

    If that doesn't help, try logging in from another account.
  7. bubulindo macrumors member


    Jul 16, 2010
    Neither here, nor there...
    Install Google Chrome...

    Unbelievably, I found this thread because my Safari was running sluggish as hell. Typing looked like I was doing it on an old 386 or something.

    So, since there was no solution on the thread and others have written that other browsers are working great I went ahead and downloaded Google Chrome.

    I downloaded it... installed it... went back to Safari and it was running as it normally does, or should have before that installation.
    I have no idea what the Chrome installation fixed, but it's working perfectly now.

    I have the 5.1 Safari and 10.6.8 MacOSX.

Share This Page