Safari text issues

Discussion in 'Mac Apps and Mac App Store' started by MarkW19, Nov 19, 2009.

  1. MarkW19 macrumors 65816

    Joined:
    Sep 13, 2002
    Location:
    Surrey, UK
    #1
    My friend's just got a new MacBook Pro, MacOS 10.6.2, latest version of Safari, and she's having problems with a lot of websites displaying some links and text strangely, as A's in boxes (pic attached). Oddly, the other 2 user accounts on her machine are fine with the same websites! She's cleared the cache, restarted Safari and her Mac (many times), changed the text encoding (and then back again), but nothing solves it.

    Can anyone help?
     

    Attached Files:

    • 1.png
      1.png
      File size:
      383.7 KB
      Views:
      395
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    Oh no, it's a virus :eek: OK, not really. It's potentially a font issue. Open up Font Book and select all of the fonts. Then, under the File menu, there's options for validating font and validating file. On occasion a font file can get corrupted, which may be the case here.

    Somewhat surprising, I was able to locate some pages by searching "safari a in square character." I found this thread that discusses seeing the A with a square around it and was a similar problem that I'm describing above. Another thread.
     
  3. naydies macrumors newbie

    Joined:
    Nov 19, 2009
    #3
    Yes, that looks like a font issue for me also. When I had the issue it was a specific helvetica and I wish I could remember the name of it but I can't. Just run the "Validate fonts" in font book like suggested above.
     
  4. MarkW19 thread starter macrumors 65816

    Joined:
    Sep 13, 2002
    Location:
    Surrey, UK
    #4
    Thanks for the replies guys, it does see like a font issue. Although, I've followed the steps at the end of that Apple thread; and have validated all of the fonts, and there were no issues with any of the web fonts, so still no luck...
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    What do you have your Text Encoding set to? You can see it in Safari by clicking View > Text Encoding
     
  6. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #6
    Some troubleshooting ideas:
    • The web site uses the fonts: "Tahoma, Verdana, Helvetica" for those parts of the page, which should mean the issue originates with one of those. Helvetica is a font that has been shown as a problem with some font issues in the past.
    • In Font Book, locate these fonts and view the preview of each of them, especially the bold variant of the font as that's what's used on the web page. I noticed in my Font Book, Tahoma's bold variant is called Negreta. Perhaps one will show those square As.
    • Try copying and pasting the text from the web page and paste it into TextEdit, Pages or Word and see how it shows up. Also see if you can figure out what font it is from the program.
     
  7. valor macrumors newbie

    Joined:
    Sep 15, 2006
    Location:
    Seattle, WA
    #7
    If you're NOT using 3rd party font management software, but have a normal install of Mac OS X, here's what fixed it for me:
    1. Open Font Book.
    -- In the far left pane, you will see something like "All Fonts," "English," "User," and "Computer."
    2. Click "User"
    3. In the middle pane, select all. Drag them over to "Computer." Font book will validate and copy the fonts.
    -- this will make all of your "local" user fonts available to everyone. (you may get an error saying you have duplicate fonts. Ignore it.)
    4. Now click on "User" again.
    5. From the "Edit" menu, choose "Disable User" option.

    Now launch Chrome and everything should display as normal.
     
  8. redhadednomad macrumors newbie

    Joined:
    Mar 21, 2010
    #8
    Font problem in Chrome

    I had the same problem, and the Font Book fix worked for me. Thanks!
     
  9. Mickyfin macrumors 6502

    Mickyfin

    Joined:
    Jan 24, 2010
    Location:
    Finland
    #9
    Thanks for the advice, however when I open fontbook, and highlight "User" there is nothing displaying in the center pane:confused:
     
  10. petetapet macrumors newbie

    Joined:
    Aug 25, 2010
    #10
    thanks so much.
    My problem has been resolved after following the above instruction of disabling the 'User'.

    Cool!
     

Share This Page