Safari tries to Hijack default Browser

Discussion in 'Mac Apps and Mac App Store' started by Chinashaw, Aug 12, 2008.

  1. Chinashaw macrumors member

    Joined:
    Aug 18, 2005
    #1
    Hi,

    I wonder if anyone has a solution to this or tried the second:

    a. Every time I click a link in Mail, it uses Safari to open the link, even though Firefox is set as the default browser, this in turn sets Safari as my default browser. This has only just started happening since the last update, so wondered if anyone else had noticed this? If they had, have you managed to prevent safari :mad: from doing this?

    b. Has anyone deleted Safari and does it have an impact on anything at all? I am just fed up with it trying to set itself as a default browser and it is a heap of ....
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
  3. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #3
    Did you set Firefox as the default browser in Safari (or within the Internet Settings)? Or did you just tell Firefox to make itself the default browser? I also believe that Mail has its own browser settings that you should set.

    TEG
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    where?
     
  5. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #5
    Works fine for me with FireFox 3 set as the default browser.
     
  6. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #6
    Likely under Preferences. I did say "I believe". I'm not entirely sure as I'm at work using XP.

    TEG
     
  7. raythemoneyman macrumors member

    raythemoneyman

    Joined:
    Jul 21, 2008
    Location:
    Tucson, Az. USA Earth
    #7
    Me to!

    I had the same problem on a PC. Changed the settings everywhere and still....Safari attack! Threw in the towel. :eek:




    http://raythemoneyman.blogspot.com
     
  8. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    I understand. I just thought you knew of something I missed. There is no such option in Mail preferences.
     
  9. Chinashaw thread starter macrumors member

    Joined:
    Aug 18, 2005
    #9
    Humble apologies

    Ok, so I did search but obviously not that well. The first link (answers, thanks for the er, seeing eye dog guide :p ) led to the answer.

    I have set the browser default in Safari to FF and done everything else. However the problem is that I use Filevault and there is a bug with that causes S*argh, to set itself as default all the time.

    I will notify Apple, though as the other comments indicated, no doubt everyone else has.

    So thanks one and all and it is off to beard the great oddity that is Jobs.
    ;)
     
  10. Chinashaw thread starter macrumors member

    Joined:
    Aug 18, 2005
    #10
  11. Chinashaw thread starter macrumors member

    Joined:
    Aug 18, 2005
    #11
    Which leads to another question

    In the Apple discussion pages, they mention deleting Safari (I never use it.) However I have heard.

    a. That to re-install Safari, you have to re-install the OS, is this true? (If so, then they are as bad as M'soft were years ago, with the whole browser integral to the OS excuse)

    b. Is there anything that won't work with Safari gone? I personally cannot think of anything and while I use Safari randomly, I cannot think of any site/action that I have to use it for.
     
  12. iTurbo macrumors member

    Joined:
    Sep 9, 2008
    #12
    I'm having the opposite problem. Whenever I click a link in Mail, it opens the link in Firefox. I don't use FF and like Safari much better. I can't find a way to set it to Safari anywhere so I have to manually drag each link down to the Safari icon in the dock.
     

Share This Page