Safari unable to launch after updating to version 5. Help please!

Discussion in 'Mac Basics and Help' started by 5hadowflam3, Jun 16, 2010.

  1. 5hadowflam3 macrumors newbie

    Joined:
    Jun 16, 2010
    #1
    Hi,

    Recently, I updated Safari to the latest version, restarted my computer, only to find safari will no longer launch. It quits unexpectedly upon attempting to start it. I have tried downloading the latest version from apple.com, but the problem persists.. I'm now forced to used Firefox, but I'd prefer to get safari working again. By the way, when reinstalling safari, I did not delete the old copy first... Would this be necessary? And if so, how? Sorry if I have not posted the relevant information. Thanks!
     
  2. forcefieldkid macrumors 6502

    Joined:
    Jan 20, 2010
    #2
    The common concensus seems to be that 3rd party plug-ins/extensions are behind the problems some are seeing with the new Safari.

    Check out this post for instructions if that's what your issue might be.

    For future reference, no you don't need to delete your current app before you use software update.
     
  3. 5hadowflam3 thread starter macrumors newbie

    Joined:
    Jun 16, 2010
    #3
    Nopee, tried that, hasn't seem to made any difference whatsoever. Safari still quits instantly. Thanks anyways! Perhaps I'll try to reinstall an old version of Safari..

    ----
    Update: Deleted Safari, made OS forget Safari50 package, reinstalled 5.0. Seems to be working fine, for now. Thank you!
     
  4. forcefieldkid macrumors 6502

    Joined:
    Jan 20, 2010
  5. MacWink macrumors newbie

    Joined:
    Jun 26, 2010
    #5
    I'm in the same jam and now I can't even put 4.1 back on.

    After the plug ins were installed my browser errors out and crashes when I try to hit the web. So I deleted the new version from the Applications folder (please tell me if you have to do more than drop it in the trash and empty it) because even though I can't see it in any folder and there is no alias on my toolbar- when I try to install 4.0 (for example) it will not let me do it because it says I have a later version already on there. If I try to put 4.1 that downloads mounts and installs but somewhere along the path it seems to automatically upgrade with those nasty plugins from yesterday that trashed it to start with so again the install of 4.1 crashes when it trys to hit the web too.

    How do I get rid safari completely so I can do a fresh install. THANK YOU:mad:
     
  6. John Doe 57 macrumors 65816

    John Doe 57

    Joined:
    Jan 26, 2008
    Location:
    Los Angeles, CA
    #6
    http://appletoolbox.com/2010/06/downgrade-from-safari-5-0-to-safari-4-0-5/
     
  7. MacWink macrumors newbie

    Joined:
    Jun 26, 2010
    #7
    Thanks John Doe 57

    I am going to download pacifist now and get on with this - I'll keep you posted THANK YOU!!!
     
  8. MacWink macrumors newbie

    Joined:
    Jun 26, 2010
    #8
    John Doe 57 you link direction worked perfectly!!

    I followed the exact directions found on the page in the link you provided and I now have a Mac who speaks Safari again. Thank you for taking the time to help me correct this problem and restore my own sanity!
     

Share This Page