Safari Unusable

Discussion in 'OS X Yosemite (10.10)' started by bearnecessities, Sep 28, 2014.

  1. bearnecessities macrumors newbie

    Joined:
    Sep 28, 2014
    #1
    Hi everyone,

    I've just installed PB3 on an early 2011 MBP. It's quite slow and stuttery overall, but I'm having a particular problem with Safari (10600.1.22). It loads up fine but will only visit a single webpage before it freezes up - and sometimes won't even make it to this first page. It doesn't crash per se; I just get a permanent beachball and have to force quit to progress.

    I've seen this problem listed a few times previously but it doesn't seem very common. Is there any kind of workaround? Chrome and Firefox work acceptably (although video is slow) and I've stopped all Safari extensions. I've checked out Activity Monitor and can't see anything that's particularly draining...

    It's not a problem if I just have to wait this one out until Oct. 21, but a workaround/advice would obviously be great if possible.

    Thanks.
     
  2. bearnecessities thread starter macrumors newbie

    Joined:
    Sep 28, 2014
    #2
    Progress...

    I tried creating a new user account; Safari loaded pages but extremely slowly.

    I returned to my main account and manually cleared all Safari-related files in ~/Library/Caches ~/Library/Preferences. It now works in my main account but is still extremely slow...

    Hopefully that helps someone. Any input on the speed? Chrome and Firefox aren't super quick but they still load pages much faster (I'm waiting around 10 seconds for each page in Safari at the moment!).
     
  3. seth556 macrumors member

    Joined:
    Sep 22, 2014
    #3
    I have an issue where everything seems to load fine but typing stuff can be painfully slow. While writing this message I could get three or four words ahead while typing of what appeared on screen. It appears to happen with Chrome too. I have the latest generation Mac Mini with a SSD.
     
  4. bearnecessities thread starter macrumors newbie

    Joined:
    Sep 28, 2014
    #4
    I've solved the issues with Safari and the general speed by reinstalling Yosemite (PB3). Everything's now super speedy.

    I held down CMD and R while booting up and followed the instructions to reinstall the OS. It took a long time (around two hours) but I managed to keep all of my files.

    So it looks like the upgrade didn't install correctly... A reinstall could definitely be worthwhile if you encounter similar issues.

    I hope this helps. :)
     

Share This Page