Safari: URL autocomplete problem

Discussion in 'Mac Apps and Mac App Store' started by omeletpants, Mar 30, 2015.

  1. omeletpants macrumors regular

    Joined:
    Oct 21, 2005
    #1
    How do I make Safari stop autocompleting my URLs. Often it takes me to a site I dont want. For example if I type in the word apple, I may not want to go to apple.com, I may just want to just search apple.
     
  2. omeletpants thread starter macrumors regular

    Joined:
    Oct 21, 2005
  3. MLinneer macrumors regular

    MLinneer

    Joined:
    Mar 18, 2013
    Location:
    Sherman, TX
    #3
    If you start typing 'apple' in the URL bar, the drop menu should populate with matches for search, history, and bookmarks.
     

    Attached Files:

  4. omeletpants thread starter macrumors regular

    Joined:
    Oct 21, 2005
    #4
    If I start typing in the word Apple it will auto fill with Applebees because I have been to that site before. I dont want it to autocomplete
     
  5. Sangoma macrumors member

    Joined:
    Dec 27, 2012
    #5
    You can just hit 'delete' before you hit 'enter'
     
  6. omeletpants thread starter macrumors regular

    Joined:
    Oct 21, 2005
    #6
    There should be a way to turn it off. Sometimes I just hate the way Apple forces us to do it their way when there could be a simple option
     

Share This Page