Safari/WebKit causes HDD to work constantly

Discussion in 'PowerPC Macs' started by bobesch, Jun 11, 2016.

  1. bobesch macrumors 6502a

    bobesch

    Joined:
    Oct 21, 2015
    Location:
    Kiel, Germany
    #1
    I didn't noticed that on my iBook/PowerBook since they are equipped with mSata-SSD, but intalling an iBookG4 for a good friend, I 've noticed now, that using Safari/WebKit causes the HDD to work heavily - even on websites without animated pictures etc. Flash has been disabled by ClickToPlugin too.
    Anyone knows the reason for that? I've nearly unchecked all settings within the browser and extensions but there had been no effect on the "noise" coming from the HDD.
    As soon as I leave the browser the HDD stops working.
    This happed on two identical iBookG4 both with HDD and I also checked both the HDD.
     
  2. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #2
    Just a thought, check Spotlight for internet related items and try disabling them, something like bookmarks, history, Google etc. Maybe Spotlight is indexing these items, hence the activity.
     
  3. bobesch thread starter macrumors 6502a

    bobesch

    Joined:
    Oct 21, 2015
    Location:
    Kiel, Germany
    #3
    Thanks for this hint!
    Now I've disabled Spotlight both with Onyx and within System-Preferences by adding the complete disk to the spotlight-"blacklist" for privacy. Didn't make any change.
    Fortunately the continous disk-activity slowed down a bit at the end of the day.
    It's not really stearable or predictable how disk-action behaves while Safari/webkit is open. But the HDD-noise stops as soon as I quit webkit/Safari. That's somehow annoying,
     
  4. B-G macrumors regular

    Joined:
    Dec 14, 2011
    #4
    I used to have the same issue. The problem was a corrupted Safari anti-phishing database. See https://discussions.apple.com/thread/2677960?tstart=0
    Disabling the "Warn when visiting a fraudulent website" option in the security pane of Safari preferences worked for me. Of course you'll need to be extra careful when visiting unfamiliar sites.
     
  5. Dronecatcher macrumors 68000

    Dronecatcher

    Joined:
    Jun 17, 2014
    Location:
    Lincolnshire, UK
    #5
    This solution always works for me.
     
  6. bobesch thread starter macrumors 6502a

    bobesch

    Joined:
    Oct 21, 2015
    Location:
    Kiel, Germany
    #6
    Thanks folks! That has been obviously the reason for the constant disk action.
    Switching that warning about "fraudulent website" option off did make silence return to the iBook.
    On my Books I've installed mSATAs. I wonder, if performance would be better without that "fraudulent website" warning too?
     
  7. Dronecatcher macrumors 68000

    Dronecatcher

    Joined:
    Jun 17, 2014
    Location:
    Lincolnshire, UK
    #7
    I'd say yes - the activity will still be there but silent. As a matter of course, on any new install as soon as I open Safari I go and untick the relevant boxes in preferences - I also close the carousel thumbnail pane in Bookmarks too - as nice as it looks I don't need it - especially after importing thousands of bookmarks from another machine.
     
  8. bobesch thread starter macrumors 6502a

    bobesch

    Joined:
    Oct 21, 2015
    Location:
    Kiel, Germany
    #8
    "close the carousel thumbnail pane..." Is it by moving the lower edge of the carousel window up, so that only the search-filed stays visible or is there another way to stop Safari making/storing previews?
     
  9. Dronecatcher macrumors 68000

    Dronecatcher

    Joined:
    Jun 17, 2014
    Location:
    Lincolnshire, UK
    #9
    Yes, that's the way I do it.
    To kill Safari making Topsite previews you enter this in Terminal:

    defaults write com.apple.Safari DebugSnapshotsUpdatePolicy -int 2
     

Share This Page