Safari will not remember my browsing history

Discussion in 'OS X El Capitan (10.11)' started by TonyDAUK, Jun 2, 2016.

  1. TonyDAUK macrumors newbie

    Joined:
    Jun 2, 2016
    Location:
    UK
    #1
    Hi,

    I updated to El Capitan at the weekend, and have noticed that Safari no longer remembers my history. It remembers any passwords previously saved but no history for any sites that I haven't bookmarked.

    I've deleted history and cookies, and under Preferences I have allow cookies from websites I've visited checked.

    Has this happened to anyone else? And, if so, is there a fix?

    Thanks in advance,
    Tony
     
  2. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #2
    Check this setting to see if it's been changed --

    Open Safari -> Safari Preferences -> General -> Safari opens with: -> from the drop-down menu make sure "A new private window" isn't selected.

    Also while in the General pane check the setting -> "Remove history items:"
     
  3. TonyDAUK thread starter macrumors newbie

    Joined:
    Jun 2, 2016
    Location:
    UK
    #3
    Hi,

    Thanks for replying, appreciated. Unfortunately, I'd already set both to 'open with a new window' and remove history 'after one year.' A bit stumped!

    Thanks again,
    Tony
     
  4. rambo47 macrumors 6502a

    rambo47

    Joined:
    Oct 3, 2010
    Location:
    Denville, NJ
    #4
    Make sure you do not have Private Browsing enabled.
     
  5. TonyDAUK thread starter macrumors newbie

    Joined:
    Jun 2, 2016
    Location:
    UK
    #5
    Thanks for replying - I'd already checked this. However, I seemed to have solved the issue after finding this on the Apple support forums (https://support.apple.com/kb/index?...x_main&locale=en_GB&q=safari+removing+history)

    This is what I did, based on a suggestion to the same problem:

    "Triple-click anywhere in the line below on this page to select it:

    ~/Library/Safari

    Right-click or control-click the line and select

    Services ▹ Open

    From the contextual menu, a folder named "Safari" should open. Quit Safari if it's running. One or more files in the open folder should have a name beginning in "History". Move those files, and only those, to the Desktop, leaving the window open. Relaunch the application and test. If there's no change, quit again and put the files you moved back where they were, overwriting the ones that may have been created in their place. Otherwise, delete the files you moved. The browser history will be empty. "

    Worked first time for me. I've closed/opened Safari several times since, over the past 12 hours, and it's remembering my history now. Hopefully fixed!
     

Share This Page