Safari won't automatically load 1password

Discussion in 'Mac Apps and Mac App Store' started by blueeye, Nov 22, 2009.

  1. blueeye macrumors member

    blueeye

    Joined:
    Oct 27, 2007
    #1
    Hi,

    I've been using 1password and have had a massive annoyance ever since I upgraded to Snow Leopard. Safari doesn't load 1password (3 - I've been using it since the beta started) the first time I use it after switching on my mac. I have to actually open 1password then refresh whatever page I wanted to use autofill on and after that it works whether I quit and reopen safari or just leave it running. This is a pain because I shouldn't have to add 1password to my startup items (that would be even more annoying). Has anyone else had this problem. I've tried various combinations of removing/adding the extension, disabling extensions (in 1password) uninstalling/reinstalling 1password, resetting Safari et cetera but none of it has made any difference.
    I've been running the latest Safari and latest 1password every time.

    Cheers.
     
  2. blueeye thread starter macrumors member

    blueeye

    Joined:
    Oct 27, 2007
    #2
    I just tried repairing permissions (which looked hopeful because a lot of Safari permission errors cropped up) but it didn't help. On reboot I still have to open 1password before Safari works with it.
     
  3. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #3
    This will be better answered on the 1Password forums or support line. Ask them.
     
  4. blueeye thread starter macrumors member

    blueeye

    Joined:
    Oct 27, 2007
    #4
    I considered it more a Safari problem but I will ask them.
     

Share This Page