Safari won't launch

Discussion in 'Mac Apps and Mac App Store' started by toontra, Nov 12, 2009.

  1. toontra macrumors 6502

    Joined:
    Feb 6, 2003
    Location:
    London UK
    #1
    Safari suddenly won't launch on my 10.5.8 system on my Powermac G5. The dock icon bounces for a few seconds then gives up. I haven't installed any new software recently.

    I've tried deleting all caches, preferences and plugins, repaired permissions, etc. It doesn't work when logged in on my spare account either.
     
  2. kroeks macrumors regular

    #2
    Hi there!
    I tried to find something for you.
    Someone else seems to have fixed the problem:

    Before doing anything I logged into my backup account - It is recommended that you create an additional admin level account in case your primary account goes wacko. From this account I discovered that I could still use Safari with no problems. This at leaset meant it was an account problem and not an Application problem. I logged back into my primary account and deleted and reinstalled Safari. This didn't help so I deleted all of the required files from the earlier thread from Ali Brown and then restarted and the same problem persisted - I had already run Repair Permissions on this account so I then logged back into my backup account and ran Repair Permissions from that account. I then logged out and logged into my primary account and Safari worked.

    If you don't have a secondary admin account you can try starting up from your OS CDs and repairing permissions from the CD.


    Hope it works for you,
    Regards, koen
     
  3. toontra thread starter macrumors 6502

    Joined:
    Feb 6, 2003
    Location:
    London UK
    #3
    Hi koen. Yes, I found that post as well after Googling! Unfortunately I think my problem is different as Safari isn't working when logged in as admin on another account. I did try the steps described though, but to no effect. Thanks anyway.
     
  4. kroeks macrumors regular

    #4
    I'll try to find some other solutions for you, but this could take some time since I'm at work. please let me know when you fixed the problem!

    -koen
     
  5. toontra thread starter macrumors 6502

    Joined:
    Feb 6, 2003
    Location:
    London UK
    #5
    Will do. Many thanks!
     

Share This Page