Safari won't play videos anymore?

Discussion in 'Mac Apps and Mac App Store' started by illjazz, Mar 8, 2010.

  1. illjazz macrumors regular

    Joined:
    Apr 18, 2008
    #1
    I don't know what happened, but somewhere along the line Safari simply stopped playing video for me. What's weird is that Youtube does work, yet none of the videos at, say, Gamespot.com work. I can't play Apple's brand-new iPad ad either, located here: http://www.apple.com/ipad/gallery/#hardware06

    Of note is that I do have ClickToFlash as well as BashFlash installed, but that never was a problem before. The videos that do not work in Safari all work, without exception, in Chrome Beta, Firefox and Opera.

    Anyone have a clue what may be causing this?

    EDIT:
    This also works: http://www.garagetv.be/video-galerij/buzzing_bees/De_kortfilm_der_logo_s.aspx
    Here's the related post: http://daringfireball.net/linked/2010/03/08/logorama

    This problem is annoying because I don't seem able to detect any sort of pattern.

    Also, I spoke too soon regarding that iPad ad. The ONLY BROWSER it worked in for me (which is *seriously* weird because everything on the Apple site tends to work with all browsers without any problems) was Firefox. On Safari the video image appears but won't load/play. I just keep getting the "watch again?" button in the middle of the image. When clicked, it'll disappear shortly, then I'm back at the same image with "watch again?" in the middle. In Opera, the video never even shows up. Just a ton of white space where the video should be. In Google Chrome, the video loads and plays... except it's all black. The area where the video should play is all black and all I hear is the sound.
    This is really, really strange.
     
  2. Michaelgtrusa macrumors 604

    Michaelgtrusa

    Joined:
    Oct 13, 2008
    Location:
    Everywhere And Nowhere
  3. dirt farmer macrumors 6502

    Joined:
    Feb 23, 2005
    #3
    With your browser open, delete: ~/Library/Preferences/Macromedia

    Trash this whole folder. Quit, then relaunch, the browser.

    Any luck?
     
  4. illjazz thread starter macrumors regular

    Joined:
    Apr 18, 2008
    #4
    Unfortunately, neither of the suggestions did the trick. I downloaded Adobe's flash player uninstaller and ran that. Then reinstalled Flash. Nothing. Same exact behavior.

    Then I trashed the Macromedia folder with Safari open. Quit. Relaunched. Same.

    The Apple ad is still broken.. I see the picture of the video and the playback controls but can't get it to play. Just says "watch again".

    I also tried this: http://www.gamespot.com/ps3/action/godofwariii/video/6253090/god-of-war-iii-video-review?hd=1

    but it won't work. I even got the age verification check to show up (isn't that Flash already?) but after that, it's stuck on buffering. The wheel keeps spinning and it keeps buffering, but it never plays. Normally, it would start playing immediately.

    Youtube continues to work. This makes no sense :/
     
  5. illjazz thread starter macrumors regular

    Joined:
    Apr 18, 2008
    #5
    Installed Safari 4.0.5. Problem went away. Weird.
     

Share This Page