Safari won't remember my full email username

Discussion in 'Mac Apps and Mac App Store' started by NewMBP13inch, Jul 22, 2009.

  1. NewMBP13inch macrumors newbie

    Joined:
    Jun 14, 2009
    #1
    The username for one of my e-mail accounts is in the format of johnsmith.numbers, but no matter what I do, Safari will only remember the text before the period (and always fills in johnsmith), forcing me to manually type in the period and the subsequent numbers every time I log into the account. I've cleared the cookies for the site and retyped it back in, but it still only fills in the stuff before the period. The account doesn't appear on my keychain (although I'm not very well-versed with that program), so that's no help.

    Any idea what I can do? It's kind of annoying having to type in my e-mail address (or at least the second half of it) every time I want to sign in.

    Thanks!
     
  2. NewMBP13inch thread starter macrumors newbie

    Joined:
    Jun 14, 2009
    #2
    I hate having to bump this, but I still haven't figured this out :(
     
  3. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #3
    This is most definitely a keychain issue. Go into Keychain Access (in your Utilities folder). Run Keychain First Aid. If it finds problems, have it repair them.
     
  4. NewMBP13inch thread starter macrumors newbie

    Joined:
    Jun 14, 2009
    #4
    Keychain First Aid didn't find any problems, unfortunately. I actually just checked out Keychain Access again, and I see that the account in question is listed. It seems to be listing the full, correct username, though (it has all of johnsmith.numbers). Still, when I actually go to the site in Safari, it only have johnsmith filled in.

    I have no idea what the problem could be.
     
  5. NewMBP13inch thread starter macrumors newbie

    Joined:
    Jun 14, 2009
    #5
    Hmm, I think I may have (kind of) found the problem.

    I cleared my cookies and deleted the keychain. Then, I manually added a keychain for that site.

    When I went back to the site, it said that Keychain Access wanted to use the information I'd provided to fill it in, so I said always allow, and it filled in the forms properly.

    The problem seems to come when I check off the box on the site that says "Remember login information"--when I do that, it only puts in the stuff before the period. I guess it's not a Safari or Keychain problem, then, but rather a website problem?
     
  6. NewMBP13inch thread starter macrumors newbie

    Joined:
    Jun 14, 2009
    #6
    Now that I've unchecked "Save login information" on the site, the forms for username/password are blank. Once I type in the first letter of my username, however, the forms properly fill in with the info I provided in Keychain Access. This is better than having to manually type in the ending of my e-mail address every time, but it's still not perfect... Is there any way to set it so that Keychain Access will automatically fill in the username/password without having to enter the first letter?
     

Share This Page