Safari "you must have latest version of flash player"

Discussion in 'Mac Apps and Mac App Store' started by EssentialParado, Jul 13, 2008.

  1. EssentialParado macrumors 65816

    Joined:
    Feb 17, 2005
    #1
    Generally whenever I go to a flash video website (like youtube or google video) it works fine, but if I try and view a video on IGN –– http://wii.ign.com/dor/objects/14248157/the-conduit/videos/raptorignne.html;jsessionid=2adnmjodq2pft –– it fails to play and gives me the error message: "You must have the latest version of Macromedia Flash Player to view this video."

    Do I have a corrupted flash player or is it a problem with the website?



    I'm on a PowerBook G4 running Leopard and the latest Safari and latest flash player.
     
  2. BlakTornado Guest

    BlakTornado

    Joined:
    Apr 24, 2007
    Location:
    Washington, OH
    #2
    Works fine for me on my iMac, using Safari 3.1.2
     
  3. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #3
    well, try re-install flash player. version 10 beta has improved speed quite a lot, you can choose good old stable ver 9 too.
     
  4. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #4
    Flash 9 or Flash 10 beta. The site works fine in the latest Flash 9.
     
  5. Salmar macrumors regular

    Joined:
    Sep 16, 2007
    Location:
    Florida
    #5
    Link and videos work fine with me using Camino browser 1.6.1
     
  6. EssentialParado thread starter macrumors 65816

    Joined:
    Feb 17, 2005
    #6
    Thanks guys. I uninstalled flash player and installed beta 10 and it's working :)
     

Share This Page