Safari

Discussion in 'Mac Apps and Mac App Store' started by Ram171, Jul 10, 2013.

  1. Ram171 macrumors member

    Ram171

    Joined:
    Apr 5, 2012
    Location:
    USA
    #1
    Ok..I've asked this question but maybe by now, someone may have figured something out..

    1. I set my preferences on Safari (i.e. uncheck "download safe files", set homepage, download file location, customize bars, uncheck "Java", etc)

    2. Works great

    3. I close Safari after use

    4. Reopen

    5. Everything is back to default and need to redo EVERYTHING...

    What the heck is this?
     
  2. ylrd macrumors member

    ylrd

    Joined:
    May 25, 2013
    Location:
    Europe
    #2
    Is your account under parental controls? Are you using Private Browsing? Do you have an automatic cleanup app installed?
     
  3. Ram171 thread starter macrumors member

    Ram171

    Joined:
    Apr 5, 2012
    Location:
    USA
    #3
    I'm the only user on the Mac so I'm the administrator. I went to parental controls under system preferences and all checks out fine. Private browsing is disabled. No cleanup app installed.
     
  4. ylrd macrumors member

    ylrd

    Joined:
    May 25, 2013
    Location:
    Europe
    #4
    Weird. Try resetting Safari (Safari > Reset Safari...) and deleting its cache:

    ~/Library/Caches/com.apple.Safari

    Also, have you made any modifications to the OS or it's been always like that? If it's the second and the cleanup doesn't work, try this:

    1. Create a new user account
    2. Give it administrator rights
    3. Backup your stuff
    4. Go to the new account, migrate your stuff and delete the old one
     
  5. Ram171 thread starter macrumors member

    Ram171

    Joined:
    Apr 5, 2012
    Location:
    USA
    #5
    I've reset safari but nothing. I checked /Library/Caches/com.apple.Safari and there's no folder.. could this be the problem?
     
  6. ylrd macrumors member

    ylrd

    Joined:
    May 25, 2013
    Location:
    Europe
    #6
    Careful there. I said
    NOT
    The ~ means the Library inside your user folder, not the System library.
     
  7. manoutdoor macrumors newbie

    Joined:
    Jul 14, 2013
    #7
    I went to parental controls under system preferences and all checks out fine[​IMG]
     

Share This Page