Safari5.0.2Leopard.dmg can't verify + other .dmg issues

Discussion in 'Mac Basics and Help' started by Padthaigf, Sep 11, 2010.

  1. Padthaigf macrumors newbie

    Joined:
    Jul 13, 2010
    #1
    Hi,

    Trying to update using Auto Update.

    Yesterday I tried to update to iTunes10 and Safari5.0.2. The iTunes install worked fine, but the Safari one wouldn't verify. I tried downloading from Apple Downloads site, still no success. When I checked the .dmg file with "Disk Utility", it gave me the following messages:

    Unable to verify "Safari5.0.2Leopard.dmg". (calculated CRC32 $0C39E5BC, expected CRC32 $290BE870)
    &
    Unable to attach "Safari5.0.2Leopard.dmg". (invalid checksum)

    I have also tried to update my Microsoft Office for Mac 2008 (since the iTunes install) and it refuses to be mounted (200MB file). I have tried it twice - once using "Microsoft Auto Update", once from the Microsoft downloads page.

    I don't know if the two problems are connected.

    I also downloaded AppCleaner, but it wouldn't go into my Apps folder because I did not have permission to alter it. I "Got Info", and added my name to the permissions list, then I was able to add again. This got me to thinking that my permissions were corrupted, so I tried to repair permissions using "Disk Utility". Report:

    ACL found but not expected on "Applications/Utilities/Network Utility.app".
    Warning: SUID file "System/Library/PrivateFrameworks/DiskManagement.framework/Versions/A/Resources/DiskManagementTool" has been modified and will not be repaired.
    Warning: SUID file "usr/sbin/pppd" has been modified and will not be repaired.
    Warning: SUID file "usr/sbin/vpnd" has been modified and will not be repaired.

    ACL found but not expected on "Applications/Utilities".

    I don't know what these mean or how to fix them.

    Any ideas on how to fix my updates/app installs?

    My system:
    iMac9,1
    Intel Core 2 Duo 2.66GHz
    Leopard 10.5.8
    L2 Cache 6MB
    Memory 4MB
     
  2. pterosaur macrumors newbie

    Joined:
    Aug 1, 2010
    #2
    So it wasn't just me! Temporary workaround here.

    I was having the same sort of problem with my new quad core i5 iMac running Snow Leopard; some disk images not recognized. The Apple tech rep verified that the problem was not with the disk images (no evidence of anything wrong with them, and they downloaded and opened OK on his computer). He talked me through removing certain *.dmg download utilities and reinstalling the operating system to get clean copies. It seemed to work for a while, then the problem recurred.

    Here's the workaround I came up with using my MacBook running Leopard. I download and open the *.dmg to my MacBook, and drag the installer package to the desktop. Then use Migration Assitant on my iMac to establish a firewire connection with my MacBook. At the stage where Migration Assistant is evaluating the sizes of the various types of files to transfer, uncheck the various types. (I am away from home, and a trifle fuzzy on the process at this point, but think I have it right. No harm done if not.) Seek out the MacBook desktop, and drag the installer package to the iMac desktop. Then eject the MacBook, disconnect, return to the iMac and run the installer package. A pain in the neck, but it works and will do until the problem is cured.
     
  3. Padthaigf thread starter macrumors newbie

    Joined:
    Jul 13, 2010
    #3
    Hmm,

    Thanks for the reply.

    Unfortunately, I am already running Leopard on my iMac (haven't upgraded to SL), and I don't own a MacBook.

    For me - I think it is something either in the the utility that verifies the .dmg, the .dmg loader/mounter, or the .dmg itself. The messaged informing me of the Checksum Error is the clue (I think).

    Would really like to get this fixed - especially the Microsoft update - as I think this would be the most vulnerable point on my computer (continually in use, always opening files created/modified on PCs - plus the major update fixing security vulnerabilities which is almost a month old).

    Update:
    I checked the info on DiskImageMounter. I am running version 10.5 ; It was modified on the 26th August 2010. I'm not sure why - I don't remember doing anything to it. In the Sharing and Permissions pane the access is as follows: System - Read&Write; Wheel - Read only; Everyone - Read Only. (I think this is normal). But when I clicked on the settings icon at the bottom of the Info box, an option opened up - Revert Changes, but it was de-activated. Could the modification to Disk Image Mounter be the problem, and if so, how can I fix it?
     
  4. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #4
    This is bad. You shouldn't be trying to work around this problem. You're downloading a file and it's corrupt (checksum failed). The problem isn't in the disk image mounter; the problem is that it's corrupt on the disk.

    Test your RAM.

    http://www.kelleycomputing.net/rember/

    Reboot your computer, don't open any other applications, and then leave this thing running overnight.
     
  5. Gee macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #5
    Progress?

    Did you make any progress with this? I have the same issue on my Air running 10.6.4. Basically, I cannot download things in Safari. Either the download crashes out half way, or – in the case of a DMG file – it downloads but then I get 'Invalid Checksum' when I try to open.

    Same thing happens with Software Update. I select updates to make, it starts off, and then says the packages cannot be used or something similar.

    Everything else functioning as normal. As noted, as well as Software Update, this has happened with a range of downloads from big companies (Filemaker, Adobe) so I'm pretty sure it's not the actual files. Thoughts?
     
  6. yvette87 macrumors newbie

    Joined:
    Nov 15, 2010
    #6
    unable to update safari or security updates

    i ran software update as per usual. it downloaded security update, safari update and itunes but would not install them. it said "some of the checked updates couldn't be saved. the digital signature for this package is incorrect. the package may have been tampered with or corrupted since being signed by "Apple". i have a macbook pro and am running 10.5.8 mac os x software. How do i fix this problem, now my windows keep closing randomly for some reason :s
     
  7. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #7
    Read what I already said. Test your RAM in single-user mode. Windows closing and programs crashing point to the same thing.
     

Share This Page