iPhone Safe Mode problem on a 5S running iOS 7.0.4

Discussion in 'Jailbreaks and iOS Hacks' started by stephen1108, Jan 8, 2014.

  1. stephen1108 macrumors 65816

    Joined:
    Sep 30, 2007
    #1
    Well, for one reason or another, my phone is getting thrown into Safe Mode. That's ok, my only problem is I'm not given any options to actually exit Safe Mode, I have to reboot my phone to exit it.

    Have others experienced this problem? Does anyone have any solutions regarding it?
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Yes, solution is start removing the last package or packages you installed.
    Something is causing an issue either with compatibility with other hacks or not fully tested or updated for your device or ios version.
     
  3. stephen1108 thread starter macrumors 65816

    Joined:
    Sep 30, 2007
    #3
    Thing is, I'm not sure what it is. I'll go back and remove tweaks one by one, but it happened today when I got a phone call, then pressed the home button to go back to the springboard. Another time it happened when a text came in and I swiped down on the notification to view NC.

    The problem seems to be with Safe Mode itself, and it not giving me the option to leave. That should disable all tweaks, right? So a tweak itself shouldn't be causing the problem?

    For example, when I force Safe Mode, there is no option to leave it. I can only reboot.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Yes, a tweak itself is causing the problem and the safe mode issue.
    Start removing one by one. Testing the phone for a while and keep going till the phone runs fine with no crashes till you find what one is the culprit. And don't install tons of stuff. Stick to things that you need and use the most.
     
  5. jt999 macrumors regular

    Joined:
    Oct 11, 2007
    #5
    I am having this problem too, and I have not isolated the problem yet.

    I have been able to exit Safe Mode with a respring through the Activator icon, which still appears in Safe Mode.
     
  6. stephen1108 thread starter macrumors 65816

    Joined:
    Sep 30, 2007
    #6
    What tweaks do you have installed? I'll list mine and maybe we can pinpoint what tweak it is? I'm thinking it MAY be Activator causing the problem, but I'm not sure.
     
  7. jt999 macrumors regular

    Joined:
    Oct 11, 2007
    #7
    I have a lot of tweaks installed.
    I too am thinking it may be Activator, but I can't bring myself to uninstall it.

    I have ruled out Bigify, Infinitidock and Adblocker, so far.
     
  8. stephen1108 thread starter macrumors 65816

    Joined:
    Sep 30, 2007
    #8
    Navigate from Maps
    Icon Tool
    Purge
    Quickshoot Pro 2
    Screenshot Dam
    Messages Customiser
    akLocationX
    Bloard
    iCleaner
    DockShift
    CCControls
    CCControls Default Themes
    HiddenSettings7
    customLS
    Flex 2 Beta
    CCClockOpenToAlarm
    ShowCase
    iTunes Radio Unlimited
    SBPowerAlert
    iFile
    Activator

    I removed all of those, but the problem is still there. :mad: I didn't remove their dependencies, but I don't think the problem lays there.
     
  9. stephen1108 thread starter macrumors 65816

    Joined:
    Sep 30, 2007
    #9
    I think it might be a Cydia Substrate problem?
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    Highly doubt it.
    If that was the case every JB 5S would have that problem.
    Its a certain package that's causing it or a conflict of 2 or more packages not playing well with each other.
     
  11. jt999 macrumors regular

    Joined:
    Oct 11, 2007
    #11
    Do you see any pattern to the timing of the crashes?
     
  12. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #12
    If you removed all tweaks then it's a dependency. not ms
     
  13. stephen1108 thread starter macrumors 65816

    Joined:
    Sep 30, 2007
    #13
    What are the standard Cydia dependencies so I know what not to remove?
     
  14. stephen1108, Jan 8, 2014
    Last edited: Jan 8, 2014

    stephen1108 thread starter macrumors 65816

    Joined:
    Sep 30, 2007
    #14
    These are the dependencies I have installed currently, all from the Packages list with the "Developer" view enabled.

    Out of these, what could be causing the issue?


    ------------------------------------------------------------------------------------------
    EDIT:
    https://twitter.com/So_Tragic/status/420085720993124352

    https://twitter.com/SaifSPathan/status/420134036976041984

    https://twitter.com/Mickyg2011/status/418661312952930304

    These other people have the same problem I do :(
     

Share This Page