iPad Safe Mode?

Discussion in 'Jailbreaks and iOS Hacks' started by engelke2010, Jul 18, 2011.

  1. engelke2010, Jul 18, 2011
    Last edited: Jul 18, 2011

    engelke2010 macrumors 6502a

    Joined:
    Mar 28, 2010
    #1
    I have a WiFi + 3G. I think I'm about to lose my jailbreak and be forced to upgrade to 4.3.4. My iPad keeps rebooting itself and I can't load Cydia to find out which tweak is causing the problem. Is there any way I can force it to boot into safe mode and fix the problem without having to restore and losing my jailbreak?
     
  2. trsblader macrumors 6502

    Joined:
    May 20, 2011
    #2
    I would also like to know the answer in case it happens to me again in the future. When it happened to me, I needed my iPad right away so I went ahead and just restored, but that was pre 4.3.4 days so I still had 4.3.3.

    I'm pretty sure the apps that screwed mine up was SlideAway. It was the last app I installed before going to bed that night, and in the morning it was having problems.
     
  3. darngooddesign, Jul 18, 2011
    Last edited: Jul 18, 2011

    darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #3
    1. In SB Settings, press on "Power" and choose "Safe Mode".

    2. Via SSH, you can navigate to the Mobile Substrate folder and delete the items. I have done this in the past when a theme kept causing problems. In 4.3.3: Library/MobileSubstrate/DynamicLibraries/... You can SSH in while its still booting, so if its rebooting too quickly try bookmarking "Library/MobileSubstrate" and delete the DynamicLibraries folder. You should have enough time to do that.
     
  4. engelke2010 thread starter macrumors 6502a

    Joined:
    Mar 28, 2010
    #4
    Thanks for your help, darngooddesign. I hope that works. It's gonna be a long day until I can try it. Ugh!
     
  5. dudeabiding macrumors 6502

    dudeabiding

    Joined:
    Aug 24, 2009
    #5
    SBSettings (the very first thing you should install after doing a jailbreak) has a mobile substrate setting under "More.". Just go in there and turn whatever you have off, then try one at a time until...
     
  6. engelke2010 thread starter macrumors 6502a

    Joined:
    Mar 28, 2010
    #6
    Thank you VERY much, darngooddesign! I think it's going to be fine and I am VERY lucky. Even though #1 didn't work and I knew wouldn't, I tried #2 with iFunbox. I deleted the folder there and rebooted. Cydia is still there, but I am thinking I should re-jailbreak and reinstall all my tweaks, one by one. I was hoping I wouldn't have had to restore because it's a 3G device and not a WiFi only so I could use TU to restore back to 4.3.3.
     
  7. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #7
    I'm glad you were able to get up and running. If you can restore back to 4.3.3 your plan seems good.

    Cheers
     
  8. ZZ Bottom macrumors 6502a

    Joined:
    Apr 14, 2010
    #8
    To the OP, FYI you can force iTunes to restore to an old firmware by holding the "option" key when you click on "restore" in the iTunes window. There are various sites that host all previous firmware versions. Here is one example: Redmondpie

    I know my instructions are very vague. A quick google search will show you in full detail how to restore to a firmware other than the current one.
     
  9. Neo7 macrumors newbie

    Joined:
    Jul 25, 2011
    Location:
    Australia
    #9
    Man you are a Genius!!!! ... and you just saves my life too.

    BTW I used TouchCopy (over USB) to delete the /DynamicLibraries folder.

    Then one quick restart and she's back to normal.

    I can't thank you enough for this tip.

    All the best.
    Neo7
     
  10. Dokk macrumors regular

    Joined:
    Jun 20, 2010
    Location:
    IA, TX ... I never know
    #10
    Y'all are gods among men and women. I went in to reset the network settings on my wife's jailbroken iPad 2 tonight and all hell broke loose. Upon respring, the UI was all shades of wrong (icons were smaller with big spaces between them, the dock was small, and the keyboard became iphone size). I forced a reboot, which brought it up under safe mode somehow (something I wasn't able to replicate in an hour of tinkering). Everything looked fine, so I rebooted and it was back to the craziness -- strange UI, I couldn't enter SBS or *any* other app, and trying to open any app whatsoever caused the screen to go crazy and the iPad to reboot.

    SBSettings was whack (just dimmed the screen and locked me out), the internet wasn't connecting (so no SSH access), and I was ready to call it quits and restore ... which my wife wasn't happy about since she hadn't backed up in a week and has been working like crazy on it.

    When all seemed lost, I saw Neo7's solution using TouchCopy over USB. I got in, deleted everything in DynamicLibraries per darngooddesign's recommendation, and everything was back to normal. WOOHOO!!! I then immediately backed up her data. :D

    I just hope this doesn't happen again when she leaves monday for a 2.5 week road trip.

    Anyway, THANK YOU ALL for being so smart!!!!!
     
  11. reeveah macrumors member

    Joined:
    Oct 23, 2008
    #11
    Pardon the long quotes... Just wanna say a big Thank You to you guys... And also, to like to highlight I had the same problem as Dokk; went to reset network settings and Duhhhhhh... Icons became smaller, and some were even blanked out, and it'll restart when you click on it...

    Google-ed (Thanks Google!!!) and found the TouchCopy solution for it... =)

    Anyway, does deleting DynamicLibraries harms your iPad 2 in any ways?
     
  12. CLUBBERMGA macrumors newbie

    Joined:
    Nov 20, 2011
    #12
    thanks @ darngooddesign

    3 years old post... I still getting used :)


    thank you for saving my iphone :):eek:
     
  13. Mac.World macrumors 68000

    Mac.World

    Joined:
    Jan 9, 2011
    Location:
    In front of uranus
    #13
    3 year old post?
     
  14. Inotrobot718 macrumors newbie

    Joined:
    Feb 2, 2014
    #14
    Stuck In Boot Recovery Loop

    Can someone please help me?

    My phone kept crashing and I looked at some sites and someone said I should go to SBS settings and disable all tweets and manually turn each on one at a time till I find the tweak that was causing the crash. After I disable all my tweaks, my phone immediately when in the boot recovery loop. I can't get into safe mode manually and I tried using Ifunbox. Ifunbox recognizes my iphone but i don't have access to the library file. Also I tried to use SSH terminal but it wont check to my phone. Please can someone help. :eek::eek::eek::eek:
     
  15. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #15
    Uninstall your tweaks from cydia one or a few at a time until the problem goes away

    You have to check to see if the tweaks are compatible with the iOS version you're on
     

Share This Page