safe way to force eject an external hard drive

Discussion in 'Mac Accessories' started by Sossity, Feb 15, 2011.

  1. Sossity macrumors 65816

    May 12, 2010
    I could not get my external hard drive to eject no matter what I did, so I resorted to force ejecting it.

    It is a 1tb external hard drive with all my music that I was using with itunes, but I had closed itunes down & had no other apps running.

    I am fairly new to macs, so looking in activity monitor to see what could have been using the disc was not much help, as I can not determine what things I need running that are crucial to the mac or not, in addition to finding what was using the drive.
  2. Fubar1977 macrumors 6502a


    Jul 30, 2010
    North Yorkshire, UK
    Odd. In Snow Leopard you usually get a message telling you which program is using the drive.
  3. Sossity thread starter macrumors 65816

    May 12, 2010
    The message I got was the drive is busy and a program is using it it cannot be ejected, & it offered me the option to force eject.

    I did not know what else to do, I went into the activity monitor, & there were a bunch of things running, but I could not determine which program was using the drive, how do I determine this if this happens again?

    dont know if this is a factor, but my external hard drive was plugged into a usb hub.
  4. sine-nomine macrumors regular

    Jul 25, 2007
    Finer stores everywhere.
    I've had a problem like this since Leopard. I find that if I copy a relatively large amount of data, say 2GB, over to any of my external hard drives, USB drives, or even disk images that trying to eject them will give me an error telling me the disk is still in use. Snow Leopard didn't resolve the issue, and the error message still never says what is using the disk.

    I've tried waiting for several days just to see if the problem sorted itself out, but I still received the error. I've tried sleeping the computer, but that didn't help, either. The only remedy I've found is to Force Quit Finder. When Finder relaunches, I can eject the disk without any problems. I don't know if this is a preferable alternative to Force Eject, but I thought I'd throw it out there.
  5. motulist macrumors 601


    Dec 2, 2003
    Meh, I say don't worry about it. Just take a look at the activity light on your hard drive, and if it's not blinking then you can feel free to just yank the cable right out. That's my opinion anyway. I've done this tons of times and my drives are fine.
  6. Sossity thread starter macrumors 65816

    May 12, 2010
    My external hard drives have on off switches on their enclosures, should I just turn it off when I see no activity from the activity light? The odd thing is, I may not see any activity right away, but then a minute later it may blink, so should I just wait for it to take a break & turn the power switch on the drive enclosure off?

    I have sometimes taken out usb flash drives this way, & then I get the red stop sign symbol telling me that I did not eject properly.

    Now that I think about it, I had been copying large files between 2 usb drives prior to turning on & working with the external hard drive, so maybe this was a factor.
  7. Sossity thread starter macrumors 65816

    May 12, 2010
    Yeah I did try force quitting finder & then relaunching, but I still could not eject it. So I took the option of force ejecting, it was the only thing that worked, it did warn it cause problems with the drive, but I did not know what else to do.
  8. Macmel macrumors 6502

    Feb 7, 2008
    Is there a difference between force-ejecting, turning off the drive and simply unplugging in from the computer?.
    I have had this problem a few times in the past 5-10 years with external HDDs and pendrives. I always just unplug them and forget about it. So far nothing has ever failed.
  9. Fisse macrumors newbie

    Aug 1, 2008
    This worked for me: Try ejecting HHD from Disk Utility.

Share This Page