Samba No Longer Working Witth Snow Leopard

Discussion in 'Mac OS X Server, Xserve, and Networking' started by icantatem, Jan 8, 2010.

  1. icantatem macrumors newbie

    Joined:
    Jul 20, 2009
    #1
    I have installed Snow Leopard in my macbook, before that, Using a belkin router I could use my brother's printer wirelessly. It was fantastic Now I just can't

    I added manually the printer and I could just call it by

    smb://MATEO-PC/hp

    and it just worked, now nothing happens I just get this annoying message telling me:

    Connection failed: NT_STATUS_BAD_NETWORK_NAME

    I could even share files with my brother calling it in finder by

    smb://MATEO-PC

    That was it now it just tells me that I might not exist or it's not available at the moment, that I should check the name or the IP.

    I've called it with the IP and nothing

    in the pc i have deactivated the password for file and print sharing so it could be easier.

    Don't know what else to say, it's just so annoying.

    PLEASE HELP!

    Oh I can't connect from the PC my mac
     
  2. Mr. Zorg macrumors regular

    Mr. Zorg

    Joined:
    Sep 5, 2007
    #2
    Try rebooting your wifi router. My wife's MacBook Air sometimes loses its connection to our printer (but nothing else). Nothing I do to the computer (rebooting, etc) helps, but rebooting the router fixes it every time.
     
  3. icantatem thread starter macrumors newbie

    Joined:
    Jul 20, 2009
    #3
    I've tried that too
     
  4. pioniere macrumors newbie

    Joined:
    Feb 28, 2009
    #4
    load Samba console from Safari, install printer following its address, then install it in the preference panel.
     
  5. KathyRo macrumors newbie

    Joined:
    Jan 26, 2010
    #5
    I've heard that removing the hyphen (dash) in the your computer's name can resolve the problem. So rename the Windows PC to MATEOPC instead of MATEO-PC.
     

Share This Page