Samsung Evo 840 fails to boot/erase/format

Discussion in 'MacBook Pro' started by Bolland, Dec 27, 2013.

  1. Bolland macrumors newbie

    Joined:
    Dec 27, 2013
    #1
    Hey guys,

    The Samsung 840 Basic is covered in some threads but I haven't found any thread tackling my problem so far:

    I have a late 2011 MacBook Pro with a Samsung SSD 840 Series installed since a couple of months. I had no errors or anything since installation and was very happy with the speed of the SSD. I installed a fresh Mavericks OS when I got it.

    A few days ago my MacBook just didn't boot, I got a spinning wheel and the apple logo for hours when powering up the machine.

    Thats what I tried so far:

    - Went through all steps on Apple help pages such as
    - SMC reset
    - NVRAM reset
    - hardware test (didn't work – spinning wheel again)
    - save mode (starts loading, then spinning wheel again)
    - Try to reinstall OS X via startup manager and then choosing Recovery boot volume: installation failed after 40-60 seconds saying "failed to download resources" (internet is working fine!). Trying again it promts: "error while preparing installation. Try again".
    - disk utility:
    - verify disk went ok
    - verify disk permissions tells me there are some groups differ, repairing disk permissions is not possible ("invalid argument")
    - repair disk: not possible (http://note.io/19nZrpe)

    I managed to boot on an old OS via external HDD. I was able to access the disk and make a backup image file out of it. I then tried to repair the SSD via Disk Utility and Terminal (diskutil).
    After not being able to repair it (same errors as above) I tried to format it using "erase". When choosing Mac OS Extended (Journaled) (or any other Mac OS Extended file systems) I get a "File system formatter failed" error (http://note.io/K8X6Fk).

    Formatting it on MS-DOS (FAT) works funnily, but that doesn't solve my problem at all :D

    I also tried setting up different partitions and changing the partition scheme, same problem appears with GUID, Apple Partition and Master Boot Record http://note.io/K8XXWl

    Right now I don't know what else to try but getting a new one from Samsung as I still have warranty.

    The only thing I haven't tried yet is a firmware update from Samsung, but I don't really think that will change anything

    Did anyone of you face the same problems or has experience with it and another hot tip for me? :)

    Thanks in advance!
    Ben
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    You might try the firmware update first.

    If that does no good, and you're fully backed up, you might return the drive for a replacement under warranty.

    If you have the warranty, use it!
     
  3. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #3
    I see you have 2 drives installed. Make sure SSD is installed in the main bay as 2011 MBP's have issues with SATA III drives in optibay.
     
  4. markx88 macrumors newbie

    Joined:
    Dec 27, 2013
    #4
    I had this exact same thing happen to me, but with a Seagate Hybrid hard drive in a mid-2012 MacBook Pro. So I suspect this isn't specific to your computer/drive combination.

    I went through all the steps you did and received all the same error messages. I would definitely attempt the firmware update.

    I had my drive mounted in an external USB dock. I was able to make a full image of it for current backup. I kept running Apple's Disk Utility on it. I restarted my computer several times. I can't really point to anything specific that I did and say, "Ah-ha, that's what made it work!" But magically and mysteriously it began working again.

    But my recommendation would be to have it replaced since it is under warranty.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    Looks to me like your SSD bit the dust. :(

    If it was working fine and you did not install anything to cause those errors, that points to a hardware problem like a failed disk.
     
  6. Sb87xx macrumors newbie

    Joined:
    Apr 28, 2014
    #6
    I'm having the exact same problem with my MB pro 2009 13" and a samsung 840 evo 500 gb ssd.

    Did you find a solution ?
     
  7. sbaker macrumors newbie

    Joined:
    Jun 23, 2014
    #7
    SATA cable

    I had a similar experience when adding an SSD (Samsung EVO 840) to a Mac mini to make my own Fusion drive; i.e. when trying to format as Mac OS Extended (Journaled) I got the "File system formatter failed" error, although I could format as MS-DOS (FAT).

    Turns out my issue was a bad SATA flex cable (purchased on ebay). I replaced it with a better cable purchased from PowerbookMedic.com, and everything is now working perfectly.
     

Share This Page