Samsung Galaxy not mounting on desktop

Discussion in 'OS X Mavericks (10.9)' started by eyeangle, Apr 30, 2014.

  1. eyeangle macrumors member

    eyeangle

    Joined:
    Jan 2, 2014
    Location:
    Melbourne, Australia
    #1
    Whenever I connect my Samsung Galaxy Mini via USB to my PC it mounts automatically but not on my mac. Do I need additional software? The phone charges and says it's connected but I can't access the SD card in it. I downloaded PdaNetMac so I'm able to connect to the internet through my android but it's just not mounting the SD card on the desktop. Please help.

    Usually when I connect to the PC an option comes up on the phone that says "Connect to PC?" and I click yes. But this doesn't happen when I connect it to my mac.
     
  2. brendu macrumors 68020

    Joined:
    Apr 23, 2009
    Location:
    USA
    #2
    On your mac, open finder and go to the menu bar at the top of the screen. Click finder and then preferences. Then make sure there is a check mark next to external disks for what to display on the desktop. Not sure if it will help your problem but it's a start.
     
  3. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #3
    Android File Transfer
     
  4. eyeangle thread starter macrumors member

    eyeangle

    Joined:
    Jan 2, 2014
    Location:
    Melbourne, Australia
    #4
    brendu > there is a check mark next to external disks.

    Partron22 > thanks this should have worked but the SD drive is still not showing up. I'm trying to find a solution but if you have any other ideas please let me know.
     
  5. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #5
    Nook HD used to need a special nook-only version of Android File Transfer.
    Have you checked the Samsung Galaxy Mini website for something like that?
    Even w the lawsuits, I'd be surprised if they didn't mention of Macs at all.
     
  6. bobdamnit macrumors regular

    Joined:
    Mar 26, 2014
    #6

Share This Page